mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
440fde6336
a/kernel-firmware-20241203_06aea4d-noarch-1.txz: Upgraded. a/kernel-generic-6.12.2-x86_64-1.txz: Upgraded. a/shadow-4.16.0-x86_64-2.txz: Rebuilt. d/cmake-3.31.2-x86_64-1.txz: Upgraded. d/gdb-15.2-x86_64-3.txz: Rebuilt. Removed files duplicated from binutils. Thanks to TommyC7 and gmgf. d/kernel-headers-6.12.2-x86-1.txz: Upgraded. k/kernel-source-6.12.2-noarch-1.txz: Upgraded. l/libppd-2.1.0-x86_64-2.txz: Rebuilt. Build without --enable-ppdc-utils. Thanks to TommyC7. l/protobuf-29.1-x86_64-1.txz: Upgraded. l/python-six-1.17.0-x86_64-1.txz: Upgraded. l/sip-6.9.0-x86_64-1.txz: Upgraded. n/postfix-3.9.1-x86_64-1.txz: Upgraded. tcl/tcl-8.6.15-x86_64-2.txz: Rebuilt. Rename sqlite3_analyzer to sqlite3_analyzer_tcl to avoid clobbering the ELF binary in the sqlite package. Likewise, rename the Thread.3 man page to Thread_tcl.3 so that we don't overwrite the one in the perl package. Thanks to TommyC7. x/fslsfonts-1.0.7-x86_64-1.txz: Upgraded. x/libdrm-2.4.124-x86_64-1.txz: Upgraded. x/libwacom-2.14.0-x86_64-1.txz: Upgraded. x/mesa-24.3.1-x86_64-1.txz: Upgraded. x/oclock-1.0.6-x86_64-1.txz: Upgraded. x/transset-1.0.4-x86_64-1.txz: Upgraded. x/xkbevd-1.1.6-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
90 lines
3 KiB
Bash
Executable file
90 lines
3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Slackware build script for python-six
|
|
|
|
# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
|
|
# Copyright 2016, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=python-six
|
|
VERSION=${VERSION:-$(echo six-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "${ARCH}" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf six-$VERSION
|
|
tar xvf $CWD/six-$VERSION.tar.*z || exit 1
|
|
cd six-$VERSION
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
python3 setup.py install --root=$PKG || exit 1
|
|
|
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a LICENSE* PKG-INFO README* $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|