mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
a1ab0f4b02
a/btrfs-progs-6.12-x86_64-1.txz: Upgraded. a/pkgtools-15.1-noarch-19.txz: Rebuilt. make-kernel-backup: report the creation of symlinks. Thanks to Mechanikx. ap/mariadb-11.4.4-x86_64-5.txz: Rebuilt. Since /etc/default/mariadb skips SSL (--skip-ssl) by default, the client side needs to do this by default also. So we've added /etc/my.cnf.d/skip-ssl.cnf to configure this, and have added comments in both files about what to change in order to enable SSL for both the client and server. Thanks to TJ09. l/alsa-lib-1.2.13-x86_64-2.txz: Rebuilt. [PATCH] UCM2: Intel: sof-hda-dsp: Fix handling of empty sys_vendor. Thanks to fulalas. l/mozjs128-128.5.1esr-x86_64-1.txz: Upgraded. l/pulseaudio-17.0-x86_64-5.txz: Rebuilt. In the X11/Wayland startup files, test the configuration better to make sure that we actually wanted autospawn before assuming we should start pulseaudio manually because autospawn wasn't working. Thanks to crtlaltca for the bug report. xap/mozilla-firefox-128.5.1esr-x86_64-1.txz: Upgraded. This is a bugfix release. For more information, see: https://www.mozilla.org/en-US/firefox/128.5.1/releasenotes/
164 lines
5.7 KiB
Bash
Executable file
164 lines
5.7 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Slackware build script for pulseaudio
|
|
|
|
# Copyright 2015 Christoph Willing Brisbane, Australia
|
|
# Copyright 2016, 2018, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=pulseaudio
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-5}
|
|
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) ARCH=i686 ;;
|
|
arm*) ARCH=arm ;;
|
|
*) ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
zcat $CWD/030_posix-completion.diff.gz | patch -p0 --verbose || exit 1
|
|
|
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1234710
|
|
zcat $CWD/0001-client-conf-Add-allow-autospawn-for-root.patch.gz | patch -p1 --verbose || exit 1
|
|
zcat $CWD/0002-allow-autospawn-for-root-default.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Do not log a warning every time root uses PulseAudio:
|
|
zcat $CWD/0003-no-root-warn.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
sed -i -e '/@PA_BINARY@/ imkdir -p \$HOME/.config/pulse' src/daemon/start-pulseaudio-x11.in
|
|
echo "X-MATE-Autostart-Phase=Initialization" >> src/daemon/pulseaudio.desktop.in
|
|
|
|
# If autospawn isn't working, start-pulseaudio-x11 should start it manually:
|
|
zcat $CWD/pulseaudio-autostart.patch.gz | patch -p1 --verbose || exit 1
|
|
# When built by meson, this patch also required to fix the above issue:
|
|
zcat $CWD/pulseaudio-autostart-meson.build.patch.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Fix 17.0 regressions:
|
|
zcat $CWD/ed3d4f0837f670e5e5afb1afa5bcfc8ff05d3407.patch.gz | patch -p1 --verbose || exit 1
|
|
zcat $CWD/f5cacd94abcc47003bd88ad7ca1450de649ffb15.patch.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Configure, build, and install:
|
|
export CFLAGS="$SLKCFLAGS"
|
|
export CXXFLAGS="$SLKCFLAGS"
|
|
mkdir meson-build
|
|
cd meson-build
|
|
meson setup \
|
|
--prefix=/usr \
|
|
--libdir=lib${LIBDIRSUFFIX} \
|
|
--libexecdir=/usr/libexec \
|
|
--bindir=/usr/bin \
|
|
--sbindir=/usr/sbin \
|
|
--includedir=/usr/include \
|
|
--datadir=/usr/share \
|
|
--mandir=/usr/man \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--buildtype=release \
|
|
-Dorc=enabled \
|
|
-Dgsettings=enabled \
|
|
-Dhal-compat=false \
|
|
-Dsystem_user="pulse" \
|
|
-Dsystem_group="pulse" \
|
|
-Daccess_group="audio" \
|
|
-Dbashcompletiondir="/usr/share/bash-completion/completions" \
|
|
.. || exit 1
|
|
"${NINJA:=ninja}" $NUMJOBS || exit 1
|
|
DESTDIR=$PKG $NINJA install || exit 1
|
|
cd ..
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Move dbus configs to system location:
|
|
mkdir -p $PKG/usr/share/dbus-1/system.d/
|
|
mv $PKG/etc/dbus-1/system.d/* $PKG/usr/share/dbus-1/system.d/
|
|
rmdir --parents $PKG/etc/dbus-1/system.d/
|
|
|
|
# Move config files to .new:
|
|
for f in $( find $PKG/etc/pulse/ -type f ) ; do mv $f $f.new ; done
|
|
mv $PKG/etc/xdg/autostart/pulseaudio.desktop $PKG/etc/xdg/autostart/pulseaudio.desktop.new
|
|
|
|
# Add an init script for system wide mode. You shouldn't use this, but we'll
|
|
# still let you if you really want.
|
|
mkdir -p $PKG/etc/rc.d
|
|
cp $CWD/rc.pulseaudio $PKG/etc/rc.d/rc.pulseaudio.new
|
|
chmod 644 $PKG/etc/rc.d/rc.pulseaudio.new
|
|
chown root:root $PKG/etc/rc.d/rc.pulseaudio.new
|
|
|
|
# PA warns in the logs if these directories are missing:
|
|
mkdir -p $PKG/etc/pulse/{default,system}.pa.d
|
|
|
|
# Compress and link manpages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
|
|
|
# Install documentation:
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a \
|
|
COPYING* *GPL LICENSE README* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|