mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
167022426d
ap/stow-2.4.0-x86_64-1.txz: Added. Thanks to r1w1s1. ap/texinfo-7.1-x86_64-2.txz: Rebuilt. Recompiled against perl-5.40.0. ap/vim-9.1.0473-x86_64-1.txz: Upgraded. Compiled against perl-5.40.0. d/ccache-4.10-x86_64-2.txz: Rebuilt. Avoid downloading doctest.h at build time. Thanks to lucabon. d/perl-5.40.0-x86_64-1.txz: Upgraded. Upgraded: DBD-mysql-4.052, Path-Tiny-0.146, URI-5.28. d/subversion-1.14.3-x86_64-2.txz: Rebuilt. Recompiled against perl-5.40.0. kde/plasma-workspace-5.27.11.1-x86_64-2.txz: Rebuilt. [PATCH] Fix writing ICEAuthority file. l/glib2-2.80.3-x86_64-1.txz: Upgraded. l/imagemagick-7.1.1_33-x86_64-2.txz: Rebuilt. Recompiled against perl-5.40.0. l/pango-1.54.0-x86_64-1.txz: Upgraded. l/python-packaging-24.1-x86_64-1.txz: Upgraded. n/epic5-2.1.12-x86_64-9.txz: Rebuilt. Recompiled against perl-5.40.0. n/irssi-1.4.5-x86_64-3.txz: Rebuilt. Recompiled against perl-5.40.0. n/net-snmp-5.9.4-x86_64-5.txz: Rebuilt. Recompiled against perl-5.40.0. n/ntp-4.2.8p18-x86_64-3.txz: Rebuilt. Recompiled against perl-5.40.0. n/openldap-2.6.8-x86_64-2.txz: Rebuilt. Recompiled against perl-5.40.0. xap/hexchat-2.16.2-x86_64-3.txz: Rebuilt. Recompiled against perl-5.40.0. xap/pidgin-2.14.13-x86_64-2.txz: Rebuilt. Recompiled against perl-5.40.0. xap/rxvt-unicode-9.31-x86_64-3.txz: Rebuilt. Recompiled against perl-5.40.0. xap/vim-gvim-9.1.0473-x86_64-1.txz: Upgraded. Compiled against perl-5.40.0. xap/xscreensaver-6.09-x86_64-1.txz: Upgraded. xfce/xfce4-power-manager-4.18.4-x86_64-1.txz: Upgraded. xfce/xfce4-session-4.18.4-x86_64-1.txz: Upgraded.
139 lines
4.1 KiB
Bash
Executable file
139 lines
4.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2015, 2017, 2018, 2019, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=pango
|
|
VERSION=${VERSION:-$(echo pango-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-pango
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG/usr
|
|
cd $TMP
|
|
rm -rf pango-$VERSION
|
|
tar xvf $CWD/pango-$VERSION.tar.?z* || exit 1
|
|
cd pango-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \; -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \;
|
|
|
|
# Configure, build, and install:
|
|
export CFLAGS="$SLKCFLAGS"
|
|
export CXXFLAGS="$SLKCFLAGS"
|
|
mkdir meson-build
|
|
cd meson-build
|
|
meson setup \
|
|
--prefix=/usr \
|
|
--libdir=lib${LIBDIRSUFFIX} \
|
|
--libexecdir=/usr/libexec \
|
|
--bindir=/usr/bin \
|
|
--sbindir=/usr/sbin \
|
|
--includedir=/usr/include \
|
|
--datadir=/usr/share \
|
|
--mandir=/usr/man \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--buildtype=release \
|
|
-Ddocumentation=false \
|
|
.. || exit 1
|
|
"${NINJA:=ninja}" $NUMJOBS || exit 1
|
|
DESTDIR=$PKG $NINJA install || exit 1
|
|
cd ..
|
|
|
|
# Do not remove pangox.aliases
|
|
#rm -f $PKG/etc/pango/pango.modules
|
|
#mkdir -p $PKG/etc/pango/$host
|
|
#touch $PKG/etc/pango/$host/pango.modules
|
|
|
|
# It seems that --mandir is ignored:
|
|
mv $PKG/usr/share/man $PKG/usr
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Compress and link manpages, if any:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.?
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
mkdir -p $PKG/usr/doc/pango-$VERSION
|
|
cp -a \
|
|
AUTHORS COPYING* NEWS README* TODO \
|
|
$PKG/usr/doc/pango-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n --prepend $TMP/pango-$VERSION-$ARCH-$BUILD.txz
|
|
|