mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
6fa0373788
a/kernel-firmware-20241209_633e866-noarch-1.txz: Upgraded. a/kernel-generic-6.12.4-x86_64-1.txz: Upgraded. a/lvm2-2.03.29-x86_64-1.txz: Upgraded. a/mcelog-202-x86_64-1.txz: Upgraded. a/pkgtools-15.1-noarch-21.txz: Rebuilt. make-kernel-backup: fix the kernel selection precedence. Thanks to Mechanikx. ap/vim-9.1.0915-x86_64-1.txz: Upgraded. d/kernel-headers-6.12.4-x86-1.txz: Upgraded. d/luajit-2.1.1732813678-x86_64-1.txz: Upgraded. d/pahole-1.28-x86_64-1.txz: Upgraded. d/rust-1.83.0-x86_64-1.txz: Upgraded. d/subversion-1.14.5-x86_64-1.txz: Upgraded. k/kernel-source-6.12.4-noarch-1.txz: Upgraded. kde/kstars-3.7.4-x86_64-1.txz: Upgraded. l/glib2-2.82.3-x86_64-1.txz: Upgraded. l/openjpeg-2.5.3-x86_64-1.txz: Upgraded. xap/vim-gvim-9.1.0915-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
125 lines
4.1 KiB
Bash
Executable file
125 lines
4.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Slackware build script for openjpeg
|
|
|
|
# Copyright 2008-2014 Heinz Wiesinger, Amsterdam, The Netherlands
|
|
# Copyright 2014, 2017, 2018, 2019 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=openjpeg
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-openjpeg
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf openjpeg-$VERSION
|
|
tar xvf $CWD/openjpeg-$VERSION.tar.?z || exit 1
|
|
cd openjpeg-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
zcat $CWD/openjpeg2_remove-thirdparty.patch.gz | patch -p1 --verbose || exit 1
|
|
|
|
mkdir -p build
|
|
cd build
|
|
cmake \
|
|
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_INSTALL_LIBDIR="lib$LIBDIRSUFFIX" \
|
|
-DOPENJPEG_INSTALL_LIB_DIR="lib$LIBDIRSUFFIX" \
|
|
-DOPENJPEG_INSTALL_MAN_DIR="man/" \
|
|
-DOPENJPEG_INSTALL_DOC_DIR="doc/openjpeg-$VERSION/" \
|
|
-DOPENJPEG_INSTALL_SHARE_DIR="share/openjpeg" \
|
|
-DBUILD_JPWL:BOOL=ON \
|
|
-DBUILD_MJ2:BOOL=ON \
|
|
-DBUILD_JPIP:BOOL=ON \
|
|
-DBUILD_JP3D:BOOL=ON \
|
|
-DBUILD_STATIC_LIBS=OFF \
|
|
.. || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
cd -
|
|
|
|
# Some libs require the openjpeg.h used for openmj2.
|
|
# This version is pretty much the old version from openjpeg 1.5
|
|
mkdir -p $PKG/usr/include/openmj2-2.1
|
|
install -m 644 src/lib/openmj2/openjpeg.h $PKG/usr/include/openmj2-2.1/
|
|
|
|
mkdir -p $PKG/usr/man
|
|
cp -r doc/man/* $PKG/usr/man/
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
|
|
mkdir -p $PKG/usr/doc/openjpeg-$VERSION
|
|
cp -a AUTHORS* CHANGES* INSTALL* LICENSE* NEWS* README* THANKS* \
|
|
$PKG/usr/doc/openjpeg-$VERSION
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/openjpeg-$VERSION-$ARCH-$BUILD.txz
|