mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
cb18a69a27
a/mkinitrd-1.4.11-x86_64-60.txz: Rebuilt. init: support having the cryptkey.bin keyfile in the initrd itself. Thanks to kursu. I took this as the simplest patch, written in the closest to the existing style. Honorable mention to Didier Spaier, opty, and RyNo (this actually might be based on RyNo's patch) for providing alternative approaches for consideration. a/pkgtools-15.1-noarch-23.txz: Rebuilt. Clean up after --dry-run better (although this matters less now that we'll be mounting a tmpfs on /var/lib/pkgtools/setup/tmp). Thanks to Mechanikx. While we're here, change tabs to spaces (only found in installpkg). a/sysvinit-3.12-x86_64-1.txz: Upgraded. a/sysvinit-scripts-15.1-noarch-24.txz: Rebuilt. rc.M: mount a tmpfs on /var/lib/pkgtools/setup/tmp. ap/man-db-2.13.0-x86_64-3.txz: Rebuilt. man-db.{csh,sh}: export MANROFFOPT=-c to fix colors with most pager. Thanks to eduardr. l/imagemagick-7.1.1_42-x86_64-1.txz: Upgraded. l/libvncserver-0.9.15-x86_64-1.txz: Upgraded. l/python-Jinja2-3.1.5-x86_64-1.txz: Upgraded. l/python-urllib3-2.3.0-x86_64-1.txz: Upgraded. x/fontconfig-2.15.0-x86_64-4.txz: Rebuilt. 60-latin.conf: Make Liberation Serif, Liberation Sans, and Liberation Mono the preferred fonts, as they were in Slackware 15.0. x/hack-fonts-ttf-3.003-noarch-4.txz: Rebuilt. I like the Hack font, but I'm not sure that it's the best default for an all- purpose monospace system font. So what we'll do is add a new file in conf.avail called 58-hack-default-monospace.conf that if symlinked into /etc/fonts/conf.d/ will make Hack the default monospace font. I'm considering adding similar override .conf files for DejaVu and Noto.
130 lines
4.3 KiB
Bash
Executable file
130 lines
4.3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2007, 2014 Heinz Wiesinger, Amsterdam, NL
|
|
# Copyright 2008, 2009, 2010, 2011, 2012, 2015, 2018, 2019, 2020, 2022 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
# Modified by Robby Workman <rworkman at slackware.com>
|
|
# Modified by Eric Hameleers <alien at slackware.com>
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=libvncserver
|
|
VERSION=${VERSION:-$(echo LibVNCServer-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
MARCH=$( uname -m )
|
|
if [ -z "$ARCH" ]; then
|
|
case "$MARCH" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$MARCH ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
case "$ARCH" in
|
|
arm*) TARGET=$ARCH-slackware-linux-gnueabi ;;
|
|
*) TARGET=$ARCH-slackware-linux ;;
|
|
esac
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-libvncserver
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf LibVNCServer-$VERSION
|
|
tar xvf $CWD/LibVNCServer-$VERSION.tar.?z || exit 1
|
|
cd *LibVNCServer-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
#zcat $CWD/libvncserver.CMAKE_INSTALL_LIBDIR.diff.gz | patch -p1 --verbose || exit 1
|
|
|
|
# Configure, build, and install:
|
|
mkdir cmake-build
|
|
cd cmake-build
|
|
cmake \
|
|
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_INSTALL_LIBDIR="lib$LIBDIRSUFFIX" \
|
|
-DCMAKE_SKIP_RPATH=ON \
|
|
-DDOC_INSTALL_DIR="doc" \
|
|
-DMAN_INSTALL_DIR=/usr/man \
|
|
-DWITH_FFMPEG=OFF \
|
|
.. || exit 1
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
cd ..
|
|
|
|
if [ -x cmake-build/client_examples/SDLvncviewer ]; then
|
|
mkdir -p $PKG/usr/bin
|
|
cp -a cmake-build/client_examples/SDLvncviewer $PKG/usr/bin/SDLvncviewer
|
|
fi
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir -p $PKG/usr/doc/libvncserver-$VERSION
|
|
cp -a \
|
|
AUTHORS* CONTRIBUTING* COPYING* ChangeLog HISTORY* NEWS* README* SECURITY* \
|
|
$PKG/usr/doc/libvncserver-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/libvncserver-$VERSION-$ARCH-$BUILD.txz
|