slackware-current/source/l/libtraceevent/libtraceevent.SlackBuild
Patrick J Volkerding 43c7ac5f45 Wed Dec 18 22:12:02 UTC 2024
a/lilo-24.2-x86_64-13.txz:  Rebuilt.
  liloconfig: add a line for /boot/initrd-generic.img if it exists, if not try
  /boot/initrd.gz, and if that's not there do not use an initrd.
  Thanks to Fuzero.
a/mkinitrd-1.4.11-x86_64-59.txz:  Rebuilt.
  /etc/default/geninitrd: now that none of lilo, elilo, or grub want that
  initrd.gz symlink, default to not creating it. If you're using lilo, you
  may need to edit lilo.conf to change from initrd.gz to initrd-generic.img.
l/libtraceevent-1.8.4-x86_64-2.txz:  Rebuilt.
  Drop static library, ship man pages. Thanks to Heinz Wiesinger.
l/libtracefs-1.8.1-x86_64-2.txz:  Rebuilt.
  Drop static library, ship man pages. Thanks to Heinz Wiesinger.
l/protobuf-29.2-x86_64-1.txz:  Upgraded.
x/xorg-server-21.1.15-x86_64-1.txz:  Upgraded.
x/xorg-server-xephyr-21.1.15-x86_64-1.txz:  Upgraded.
x/xorg-server-xnest-21.1.15-x86_64-1.txz:  Upgraded.
x/xorg-server-xvfb-21.1.15-x86_64-1.txz:  Upgraded.
xfce/Greybird-3.23.4-noarch-1.txz:  Upgraded.
extra/brltty/brltty-6.7-x86_64-4.txz:  Rebuilt.
  Fixed redundant misplaced TCL_DIR. Thanks to chrisretusn.
extra/tigervnc/tigervnc-1.14.1-x86_64-3.txz:  Rebuilt.
  Rebuilt against xorg-server-21.1.15.
2024-12-19 00:01:31 +01:00

122 lines
3.6 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libtraceevent
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
make \
$NUMJOBS \
prefix=/usr \
V=1 \
DESTDIR=$PKG \
install || exit 1
make \
$NUMJOBS \
prefix=/usr \
mandir=/usr/man \
htmldir=/usr/doc/$PKGNAM-$VERSION/html \
V=1 \
DESTDIR=$PKG \
doc-install || exit 1
# The HTML docs just duplicate the man pages, so don't ship them:
rm -rf $PKG/usr/doc/$PKGNAM-$VERSION/html
# Drop static library:
rm -f $PKG/usr/lib$LIBDIRSUFFIX/libtraceevent.a
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
LICENSES/* README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz