mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
c163a6350b
a/btrfs-progs-6.11-x86_64-1.txz: Upgraded. a/dracut-103-x86_64-1.txz: Added. This is Red Hat's tool to generate an initramfs (aka initrd). Around here, we try not to suffer from Not Invented Here Syndrome (some might say the less we invent, the better ;-). It never hurts to have additional options, and it even looks like our old friend David Cantrell is on the AUTHORS list. I've had good luck here with: dracut --hostonly --force /boot/initrd-6.10.11-generic.img Thanks to Didier Spaier for convincing me to try it out. a/gawk-5.3.1-x86_64-1.txz: Upgraded. a/kernel-generic-6.10.11-x86_64-1.txz: Upgraded. a/upower-1.90.6-x86_64-1.txz: Upgraded. d/kernel-headers-6.10.11-x86-1.txz: Upgraded. k/kernel-source-6.10.11-noarch-1.txz: Upgraded. l/libtiff-4.7.0-x86_64-1.txz: Upgraded. n/curl-8.10.1-x86_64-1.txz: Upgraded. x/mesa-24.2.3-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
131 lines
4.2 KiB
Bash
Executable file
131 lines
4.2 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2004, 2005, 2006, 2009, 2010, 2011, 2012, 2013, 2015, 2018, 2022, 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=libtiff
|
|
VERSION=${VERSION:-$(echo tiff-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-libtiff
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $PKG
|
|
cd $TMP
|
|
rm -rf tiff-$VERSION
|
|
tar xvf $CWD/tiff-$VERSION.tar.?z || exit 1
|
|
cd tiff-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Apply upstream patches (if any):
|
|
for patch in $CWD/patches/*.patch.gz ; do
|
|
zcat $patch | patch -p1 --verbose || exit 1
|
|
done
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--disable-static \
|
|
--program-prefix="" \
|
|
--program-suffix="" \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
( cd man ; make install-man DESTDIR=$PKG || exit 1 ) || exit 1
|
|
rm -r $PKG/usr/share
|
|
( cd $PKG
|
|
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
)
|
|
strip -g $PKG/usr/lib${LIBDIRSUFFIX}/lib*.a
|
|
chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/libtiff*.so.*
|
|
mkdir -p $PKG/usr/doc/libtiff-$VERSION
|
|
cp -a \
|
|
COPYRIGHT README RELEASE-DATE TODO VERSION \
|
|
$PKG/usr/doc/libtiff-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mv $PKG/usr/local/man $PKG/usr
|
|
rmdir $PKG/usr/local
|
|
|
|
# I'd use that shiny new manpage script here but all the
|
|
# .3 manpages end with '.3tiff'.
|
|
gzip -9 $PKG/usr/man/man?/*
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
makepkg -l y -c n $TMP/libtiff-$VERSION-$ARCH-$BUILD.txz
|
|
|