slackware-current/source/l/libev/libev.SlackBuild
Patrick J Volkerding 25d8b003ae Sun Oct 22 19:30:42 UTC 2023
a/lvm2-2.03.22-x86_64-1.txz:  Upgraded.
kde/kstars-3.6.7-x86_64-1.txz:  Upgraded.
  It's time for KStars in Slackware to be less of a toy and more of a useful
  tool. The required dependencies have been added for EKOS, the INDI client
  included in KStars, which will allow for computer control of astronomy
  devices. Additional deps and drivers may be required, but these are runtime
  dependencies. See (for example) gpsd, libdc1394, libftdi1, libindi-libraries,
  and libindi-drivers, all of which can be found on slackbuilds.org.
  Huge thanks to Edward W. Koenig for the detailed writeup - it was extremely
  helpful! :-) Here's a link to the article:
  https://www.linuxgalaxy.org/kingbeowulf/astronomy-device-control-in-slackware-15-and-current/
kde/libindi-2.0.4-x86_64-1.txz:  Added.
  This is required by kstars-3.6.7.
kde/libnova-0.15.0-x86_64-1.txz:  Added.
  This is required by kstars-3.6.7.
  Thanks to Chris Abela, Ryan P.C. McQuen, and Philip Lacroix.
kde/stellarsolver-2.5-x86_64-1.txz:  Added.
  This is required by kstars-3.6.7.
kde/wcslib-8.1-x86_64-1.txz:  Added.
  This is required by kstars-3.6.7.
l/LibRaw-0.21.1-x86_64-2.txz:  Rebuilt.
  This update fixes a security issue:
  A heap-buffer-overflow was found in raw2image_ex(int), which may lead to
  application crash by maliciously crafted input file.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-1729
  (* Security fix *)
l/imagemagick-7.1.1_21-x86_64-1.txz:  Upgraded.
l/libev-4.33-x86_64-1.txz:  Added.
  This is required by kstars-3.6.7.
  As this package may have more general usage than just kstars, we'll put it
  in the L series.
  Thanks to AA ime Ramov and Matteo Bernardini.
l/vte-0.74.1-x86_64-1.txz:  Upgraded.
2023-10-22 22:00:59 +02:00

163 lines
5 KiB
Bash
Executable file

#!/bin/bash
# Written by AA ime Ramov <s@ramov.com>
# Maintained (2012-2020) by Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# Copyright 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Written by Šime Ramov <s@ramov.com>
# Maintained (2012-2020) by Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# Rewritten by Patrick Volkerding <volkerdi@slackware.com>, 2023
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libev
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i586 ;;
arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "armv7hl" ]; then
SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
LIBDIRSUFFIX=""
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Configure, build, and install:
if [ ! -r configure ]; then
if [ -x ./autogen.sh ]; then
NOCONFIGURE=1 ./autogen.sh
else
autoreconf -vif
fi
fi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--mandir=/usr/man \
--infodir=/usr/info \
--disable-static \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
# avoid conflicting with libevent, we move an header in a subfolder
# and we will explicitly add CPPFLAGS="-I/usr/include/libev" when
# building software depending on this, if needed: lighttpd2 and i3,
# for example, don't need this header.
mkdir -p $PKG/usr/include/libev
mv $PKG/usr/include/event.h $PKG/usr/include/libev/
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Compress info files, if any:
if [ -d $PKG/usr/info ]; then
( cd $PKG/usr/info
rm -f dir
gzip -9 *
)
fi
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
Changes LICENSE* README* TODO* \
$PKG/usr/doc/${PKGNAM}-$VERSION
# If there's a Changes file, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r Changes ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat Changes | head -n 1000 > $DOCSDIR/Changes
touch -r Changes $DOCSDIR/Changes
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz