slackware-current/source/l/libcanberra/libcanberra.SlackBuild
Patrick J Volkerding bd42aca52d Tue Feb 1 04:37:04 UTC 2022
The sepulchral voice intones, "The cave is now closed."
kde/falkon-3.2.0-x86_64-1.txz:  Upgraded.
kde/ktexteditor-5.90.0-x86_64-2.txz:  Rebuilt.
  [PATCH] only start programs in user's path.
  [PATCH] only execute diff in path.
  Thanks to gmgf.
  For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-23853
  (* Security fix *)
l/libcanberra-0.30-x86_64-9.txz:  Rebuilt.
  Fix a bug crashing some applications in Wayland desktops.
  Thanks to 01micko.
n/samba-4.15.5-x86_64-1.txz:  Upgraded.
  This is a security release in order to address the following defects:
  UNIX extensions in SMB1 disclose whether the outside target of a symlink
  exists.
  Out-of-Bound Read/Write on Samba vfs_fruit module. This vulnerability
  allows remote attackers to execute arbitrary code as root on affected Samba
  installations that use the VFS module vfs_fruit.
  Re-adding an SPN skips subsequent SPN conflict checks. An attacker who has
  the ability to write to an account can exploit this to perform a
  denial-of-service attack by adding an SPN that matches an existing service.
  Additionally, an attacker who can intercept traffic can impersonate existing
  services, resulting in a loss of confidentiality and integrity.
  For more information, see:
    https://www.samba.org/samba/security/CVE-2021-44141.html
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44141
    https://www.samba.org/samba/security/CVE-2021-44142.html
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-44142
    https://www.samba.org/samba/security/CVE-2022-0336.html
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-0336
  (* Security fix *)
x/xterm-370-x86_64-7.txz:  Rebuilt.
  Rebuilt with --disable-sixel-graphics to fix a buffer overflow.
  Thanks to gmgf.
  For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24130
  (* Security fix *)
testing/source/linux-5.16.4-configs/*:  Added.
  Sample config files to build 5.16.4 Linux kernels.
2022-02-01 08:59:52 +01:00

122 lines
4 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2010, 2011, 2012, 2015 Robby Workman, Tuscaloosa, Alabama, USA
# Copyright 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libcanberra
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-9}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
# If this package is being built for ALSA (no PulseAudio), use the _alsa $TAG:
if [ ! -r /usr/lib${LIBDIRSUFFIX}/pkgconfig/libpulse.pc ]; then
TAG="_alsa"
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.txz"
exit 0
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
zcat $CWD/libcanberra-0.30-wayland-1.patch.gz | patch -p1 --verbose || exit 1
CFLAGS="$SLKCFLAGS -I/usr/include/samba-4.0" \
CXXFLAGS="$SLKCFLAGS -I/usr/include/samba-4.0" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--disable-static \
--disable-oss \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
# Don't ship .la files:
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a COPYING* LGPL README* $PKG/usr/doc/$PKGNAM-$VERSION
( cd $PKG/usr/doc/$PKGNAM-$VERSION ; ln -s ../../share/gtk-doc/html/libcanberra html )
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.txz