slackware-current/source/l/gtkspell/gtkspell.SlackBuild
Patrick J Volkerding c01ee3e653 Wed Jun 30 03:45:31 UTC 2021
a/kernel-firmware-20210629_d79c267-noarch-1.txz:  Upgraded.
ap/cups-2.3.3op2-x86_64-1.txz:  Upgraded.
kde/lokalize-21.04.2-x86_64-2.txz:  Rebuilt.
  Recompiled against hunspell-1.7.0.
kde/sonnet-5.83.0-x86_64-2.txz:  Rebuilt.
  Recompiled against hunspell-1.7.0.
l/enchant-2.3.0-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
l/gtkspell-2.0.16-x86_64-7.txz:  Rebuilt.
  Recompiled against enchant-2.3.0.
l/hunspell-1.7.0-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
l/python-urllib3-1.26.6-x86_64-2.txz:  Rebuilt.
  Don't build python2 version.
l/python2-module-collection-2.7.18-x86_64-4.txz:  Rebuilt.
  Upgraded to urllib3-1.25.11 for compatibility with requests.
  Thanks to USUARIONUEVO.
l/qt5-5.15.2-x86_64-10.txz:  Rebuilt.
  Recompiled against hunspell-1.7.0.
n/php-7.4.21-x86_64-1.txz:  Upgraded.
  This update fixes bugs and security issues:
  Core: SSRF bypass in FILTER_VALIDATE_URL.
  PDO_Firebird: Stack buffer overflow in firebird_info_cb.
  PDO_Firebird: SIGSEGV in firebird_handle_doer.
  PDO_Firebird: SIGSEGV in firebird_stmt_execute.
  PDO_Firebird: Crash while parsing blob data in firebird_fetch_blob.
  For more information, see:
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21705
    https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21704
  (* Security fix *)
xap/pan-0.146-x86_64-5.txz:  Rebuilt.
  Recompiled against enchant-2.3.0.
extra/php8/php8-8.0.8-x86_64-1.txz:  Upgraded.
2021-06-30 08:59:54 +02:00

142 lines
4.1 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2006, 2008, 2009, 2010, 2018, 2021 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gtkspell
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-7}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-${PKGNAM}
rm -rf $PKG
mkdir -p $TMP $PKG
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
cd $TMP
rm -rf ${PKGNAM}-${VERSION}
tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
cd ${PKGNAM}-$VERSION || exit 1
# Make sure ownerships and permissions are sane:
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
zcat $CWD/gtkspell.enchant-2.diff.gz | patch -p1 --verbose || exit 1
# Regenerate build system to fix newer gtk-doc dropping gtkdoc-mktmpl:
gtkdocize
autoreconf -vif
# Configure:
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--mandir=/usr/man \
--infodir=/usr/info \
--disable-static \
--build=$ARCH-slackware-linux || exit 1
# Build and install:
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
# Compress info files, if any:
if [ -d $PKG/usr/info ]; then
( cd $PKG/usr/info
rm -f dir
gzip -9 *
)
fi
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
AUTHORS COPYING* INSTALL NEWS README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $TMP/package-${PKGNAM}
/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz