mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
4d6224ab70
ap/ksh93-1.0.9-x86_64-1.txz: Upgraded. kde/calligra-3.2.1-x86_64-42.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/cantor-23.08.5-x86_64-8.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/kfilemetadata-5.116.0-x86_64-4.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/kile-2.9.93-x86_64-35.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/kitinerary-23.08.5-x86_64-6.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/krita-5.2.3-x86_64-2.txz: Rebuilt. Recompiled against poppler-24.07.0. kde/okular-23.08.5-x86_64-6.txz: Rebuilt. Recompiled against poppler-24.07.0. l/ffmpeg-6.1.1-x86_64-4.txz: Rebuilt. Recompiled against libplacebo-7.349.0. l/gdbm-1.24-x86_64-1.txz: Upgraded. l/libplacebo-7.349.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/poppler-24.07.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/python-trove-classifiers-2024.7.2-x86_64-1.txz: Upgraded. n/getmail-6.19.02-x86_64-1.txz: Upgraded. n/httpd-2.4.60-x86_64-2.txz: Rebuilt. This update is to fix a regression and to note security issues that were not listed in the CHANGES file included with the source code. Fixed a regression where a config file using AddType rather than AddHandler could cause raw PHP files to be downloaded rather than processed. Thanks to Nobby6. For more information, see: https://downloads.apache.org/httpd/CHANGES_2.4.60 https://www.cve.org/CVERecord?id=CVE-2024-39573 https://www.cve.org/CVERecord?id=CVE-2024-38477 https://www.cve.org/CVERecord?id=CVE-2024-38476 https://www.cve.org/CVERecord?id=CVE-2024-38475 https://www.cve.org/CVERecord?id=CVE-2024-38474 https://www.cve.org/CVERecord?id=CVE-2024-38473 https://www.cve.org/CVERecord?id=CVE-2024-38472 https://www.cve.org/CVERecord?id=CVE-2024-36387 (* Security fix *) xap/mpv-0.38.0-x86_64-4.txz: Rebuilt. Recompiled against libplacebo-7.349.0.
128 lines
3.9 KiB
Bash
Executable file
128 lines
3.9 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2016, 2017, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
# Build gdbm-$VERSION for Slackware
|
|
# by volkerdi@slackware.com, 2/2001
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=gdbm
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-gdbm
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
cd $TMP
|
|
rm -rf gdbm-$VERSION
|
|
tar xvf $CWD/gdbm-$VERSION.tar.?z || exit 1
|
|
cd gdbm-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--infodir=/usr/info \
|
|
--mandir=/usr/man \
|
|
--disable-static \
|
|
--enable-libgdbm-compat \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
( cd $PKG/usr/man
|
|
find . -type f -exec gzip -9 {} \+
|
|
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
|
)
|
|
|
|
mkdir -p $PKG/usr/doc/gdbm-$VERSION
|
|
cp -a \
|
|
ABOUT-NLS AUTHORS COPYING* NEWS NOTE-WARNING README* THANKS \
|
|
$PKG/usr/doc/gdbm-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
rm -f $PKG/usr/info/dir
|
|
gzip -9 $PKG/usr/info/gdbm.info
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
makepkg -l y -c n $TMP/gdbm-$VERSION-$ARCH-$BUILD.txz
|
|
|