slackware-current/source/l/audiofile/audiofile.SlackBuild
Patrick J Volkerding 4efc82d829 Sun Nov 20 00:54:24 UTC 2022
a/aaa_libraries-15.1-x86_64-13.txz:  Rebuilt.
  Upgraded: libelf-0.188.so, liblzma.so.5.2.8, libmpfr.so.6.1.1.
  Removed: libunistring.so.2.1.0.
  Added: libFLAC++.so.6.3.0, libFLAC.so.8.3.0, libjasper.so.6.0.0.
ap/flac-1.4.2-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
ap/moc-2.6_alpha3-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
ap/opus-tools-0.2-x86_64-4.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
ap/sox-14.4.2-x86_64-9.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
ap/vorbis-tools-1.4.2-x86_64-3.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
kde/audiocd-kio-22.08.3-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
kde/digikam-7.8.0-x86_64-4.txz:  Rebuilt.
  Recompiled against jasper-4.0.0.
kde/k3b-22.08.3-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
kde/kid3-3.9.2-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
kde/kwave-22.08.3-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
l/LibRaw-0.20.2-x86_64-6.txz:  Rebuilt.
  Recompiled against jasper-4.0.0.
l/at-spi2-core-2.46.0-x86_64-1.txz:  Upgraded.
l/audiofile-0.3.6-x86_64-5.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
l/gamin-0.1.10-x86_64-9.txz:  Removed.
l/gegl-0.4.40-x86_64-2.txz:  Rebuilt.
  Recompiled against jasper-4.0.0.
l/glib-networking-2.74.0-x86_64-1.txz:  Upgraded.
l/glib2-2.74.1-x86_64-1.txz:  Upgraded.
l/gobject-introspection-1.74.0-x86_64-1.txz:  Upgraded.
l/gst-plugins-good-1.20.4-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
l/jasper-4.0.0-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
l/libsndfile-1.1.0-x86_64-2.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
l/libsoup-2.74.3-x86_64-1.txz:  Upgraded.
l/pango-1.50.12-x86_64-1.txz:  Upgraded.
l/pygobject3-3.42.2-x86_64-1.txz:  Upgraded.
l/qt5-5.15.7_20221116_ee27a432-x86_64-1.txz:  Upgraded.
  Compiled against jasper-4.0.0.
l/sdl-1.2.15-x86_64-13.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
l/vte-0.70.1-x86_64-1.txz:  Upgraded.
xap/audacious-plugins-4.2-x86_64-3.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
xap/easytag-2.4.3-x86_64-5.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
xap/xine-lib-1.2.12-x86_64-3.txz:  Rebuilt.
  Recompiled against flac-1.4.2.
2022-11-20 07:00:14 +01:00

148 lines
4.3 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2006, 2007, 2008, 2009, 2010, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=audiofile
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-5}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-${PKGNAM}
rm -rf $PKG
mkdir -p $TMP $PKG
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
cd $TMP
rm -rf ${PKGNAM}-${VERSION}
tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
cd ${PKGNAM}-$VERSION || exit 1
# Make sure ownerships and permissions are sane:
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Configure:
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man \
--program-prefix= \
--program-suffix= \
--build=$ARCH-slackware-linux || exit 1
# Build and install:
make $NUMJOBS || exit 1
make install DESTDIR=$PKG || exit 1
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
# Strip binaries:
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.*
)
done
)
fi
# Compress info files, if any:
if [ -d $PKG/usr/info ]; then
( cd $PKG/usr/info
rm -f dir
gzip -9 *
)
fi
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
COPYING* TODO README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz