mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
a1ab0f4b02
a/btrfs-progs-6.12-x86_64-1.txz: Upgraded. a/pkgtools-15.1-noarch-19.txz: Rebuilt. make-kernel-backup: report the creation of symlinks. Thanks to Mechanikx. ap/mariadb-11.4.4-x86_64-5.txz: Rebuilt. Since /etc/default/mariadb skips SSL (--skip-ssl) by default, the client side needs to do this by default also. So we've added /etc/my.cnf.d/skip-ssl.cnf to configure this, and have added comments in both files about what to change in order to enable SSL for both the client and server. Thanks to TJ09. l/alsa-lib-1.2.13-x86_64-2.txz: Rebuilt. [PATCH] UCM2: Intel: sof-hda-dsp: Fix handling of empty sys_vendor. Thanks to fulalas. l/mozjs128-128.5.1esr-x86_64-1.txz: Upgraded. l/pulseaudio-17.0-x86_64-5.txz: Rebuilt. In the X11/Wayland startup files, test the configuration better to make sure that we actually wanted autospawn before assuming we should start pulseaudio manually because autospawn wasn't working. Thanks to crtlaltca for the bug report. xap/mozilla-firefox-128.5.1esr-x86_64-1.txz: Upgraded. This is a bugfix release. For more information, see: https://www.mozilla.org/en-US/firefox/128.5.1/releasenotes/
159 lines
5 KiB
Bash
Executable file
159 lines
5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2012, 2013, 2015, 2016, 2018, 2019, 2020, 2021, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=alsa-lib
|
|
VERSION=${VERSION:-$(echo alsa-lib-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-2}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-alsa-lib
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# If this package is being built for ALSA (no PulseAudio), use the _alsa $TAG:
|
|
if [ ! -r /usr/lib${LIBDIRSUFFIX}/pkgconfig/libpulse.pc ]; then
|
|
TAG="_alsa"
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD$TAG.txz"
|
|
exit 0
|
|
fi
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf alsa-lib-$VERSION
|
|
tar xvf $CWD/alsa-lib-$VERSION.tar.?z || exit 1
|
|
cd alsa-lib-$VERSION || exit 1
|
|
|
|
# Fix file missing in 1.1.6:
|
|
if [ ! -r src/conf/smixer.conf ]; then
|
|
cp -a $CWD/smixer.conf src/conf
|
|
fi
|
|
|
|
# Untar the configuration files. We'll install them later.
|
|
( mkdir ucm-and-topology-configs
|
|
cd ucm-and-topology-configs
|
|
for file in $CWD/alsa-*conf*tar.lz ; do
|
|
tar xvf $file
|
|
mv $(basename $file | cut -f 1-3 -d -)-*/* .
|
|
rmdir $(basename $file | cut -f 1-3 -d -)-*
|
|
mv README.md README-$(echo $(basename $file) | cut -f 1-3 -d -)
|
|
done
|
|
# Apply upstream patch:
|
|
cd ucm2
|
|
cat $CWD/11b028a9a01e47fc9b48e4a566803752011902e2.patch | patch -p2 --verbose || exit 1
|
|
) || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--enable-mixer-modules \
|
|
--enable-topology \
|
|
--enable-ucm \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir $PKG/etc
|
|
if [ "$TAG" = "_alsa" ]; then
|
|
# Ship an empty asound.conf for ALSA-only system:
|
|
cp -a $CWD/asound.conf.alsa $PKG/etc/asound.conf.new
|
|
else
|
|
# Redirect to PulseAudio:
|
|
cp -a $CWD/asound.conf.pulse $PKG/etc/asound.conf.new
|
|
fi
|
|
chmod 644 $PKG/etc/asound.conf.new
|
|
chown root:root $PKG/etc/asound.conf.new
|
|
|
|
# Install ucm and topology configs:
|
|
( cd ucm-and-topology-configs ; tar cf - . ) | ( cd $PKG/usr/share/alsa ; tar xf -)
|
|
|
|
# TODO?
|
|
# ( cd src/pcm/ext
|
|
# make jack
|
|
# make jack-install )
|
|
|
|
mkdir -p $PKG/usr/doc/alsa-lib-$VERSION
|
|
cp -a \
|
|
INSTALL MEMORY-LEAK NOTES TODO \
|
|
$PKG/usr/doc/alsa-lib-$VERSION
|
|
cp -a COPYING $PKG/usr/doc/alsa-lib-$VERSION/COPYING.lib
|
|
cp -a aserver/COPYING $PKG/usr/doc/alsa-lib-$VERSION/COPYING.aserver
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/alsa-lib-$VERSION-$ARCH-$BUILD$TAG.txz
|
|
|