slackware-current/source/l/PyQt-builder/PyQt-builder.SlackBuild
Patrick J Volkerding 41196c6ff1 Fri Dec 6 22:22:58 UTC 2024
a/kernel-generic-6.12.3-x86_64-1.txz:  Upgraded.
a/mkinitrd-1.4.11-x86_64-53.txz:  Rebuilt.
  /etc/default/geninitrd: added option AUTO_UPDATE_GRUB=true to run update-grub
  after generating the initrd.
  Move the remove-orphaned-initrds section from geninitrd to setup.01.mkinitrd.
  setup.01.mkinitrd: support AUTO_UPDATE_GRUB. Suppress warnings from
  libdevmapper when setup.01.mkinitrd is run within upgradepkg's flock locking.
a/pkgtools-15.1-noarch-20.txz:  Rebuilt.
  pkgtool: set INSIDE_INSTALLER in the Setup section to match the expected
  behavior. Thanks to Mechanikx.
  upgradepkg: allow text produced by install scripts to reach the console in
  --terse mode.
d/kernel-headers-6.12.3-x86-1.txz:  Upgraded.
k/kernel-source-6.12.3-noarch-1.txz:  Upgraded.
l/PyQt-builder-1.17.0-x86_64-1.txz:  Upgraded.
l/sof-firmware-2024.09.2-noarch-1.txz:  Upgraded.
l/xapian-core-1.4.27-x86_64-1.txz:  Upgraded.
x/mesa-24.3.1-x86_64-2.txz:  Rebuilt.
  Revert commit 4c065158927d7bacc5eb1e4f2491b1db93f1dc12:
  [PATCH] dri: revert INVALID modifier special-casing.
  This fixes a crash with AMD RX 470 through 590.
  Thanks to genss for the bug report.
xfce/xfce4-pulseaudio-plugin-0.4.9-x86_64-1.txz:  Upgraded.
isolinux/initrd.img:  Rebuilt.
kernels/*:  Upgraded.
usb-and-pxe-installers/usbboot.img:  Rebuilt.
2024-12-07 00:44:23 +01:00

109 lines
3.7 KiB
Bash
Executable file

#!/bin/sh
# Copyright 2023, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=PyQt-builder
SRCNAM=pyqt_builder
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz"
exit 0
fi
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
elif [ "$ARCH" = "armv7hl" ]; then
SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
else
SLKCFLAGS="-O2"
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z || exit 1
cd $SRCNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
python3 -m build --wheel --no-isolation || exit 1
python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Remove Windows garbage:
find $PKG . -name "*.exe" -exec rm -f "{}" \;
find $PKG . -name "*.dll" -exec rm -f "{}" \;
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
LICENSE* COPYING* ChangeLog NEWS README TODO doc/* \
$PKG/usr/doc/$PKGNAM-$VERSION
chown -R root:root $PKG/usr/doc
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$(echo $VERSION |tr - _)-$ARCH-$BUILD.txz