mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
194d2d2fc5
a/dracut-104-x86_64-1.txz: Upgraded. d/cmake-3.30.5-x86_64-1.txz: Upgraded. d/subversion-1.14.4-x86_64-1.txz: Upgraded. l/mozjs128-128.3.1esr-x86_64-1.txz: Upgraded. l/openexr-3.3.1-x86_64-1.txz: Upgraded. l/python-charset-normalizer-3.4.0-x86_64-1.txz: Upgraded. x/fcitx5-5.1.11-x86_64-1.txz: Upgraded. x/fcitx5-anthy-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-chinese-addons-5.1.7-x86_64-1.txz: Upgraded. x/fcitx5-hangul-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-kkc-5.1.5-x86_64-1.txz: Upgraded. x/fcitx5-m17n-5.1.2-x86_64-1.txz: Upgraded. x/fcitx5-qt-5.1.7-x86_64-1.txz: Upgraded. x/fcitx5-unikey-5.1.5-x86_64-1.txz: Upgraded. x/libime-1.1.9-x86_64-1.txz: Upgraded. xap/mozilla-firefox-128.3.1esr-x86_64-1.txz: Upgraded. This update contains a critical security fix: Use-after-free in Animation timeline. "An attacker was able to achieve code execution in the content process by exploiting a use-after-free in Animation timelines. We have had reports of this vulnerability being exploited in the wild." For more information, see: https://www.mozilla.org/en-US/firefox/128.3.1/releasenotes/ https://www.mozilla.org/security/advisories/mfsa2024-51/ https://www.cve.org/CVERecord?id=CVE-2024-9680 (* Security fix *)
202 lines
6.6 KiB
Bash
Executable file
202 lines
6.6 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2011, 2012, 2015, 2018, 2020, 2021 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=subversion
|
|
VERSION=${VERSION:-$(echo subversion-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# GCC 14 "fix":
|
|
SLKCFLAGS="$SLKCFLAGS -Wno-error=incompatible-pointer-types -Wno-error=int-conversion"
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-subversion
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf subversion-$VERSION
|
|
tar xvf $CWD/subversion-$VERSION.tar.?z* || exit 1
|
|
cd subversion-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
if [ "$VERSION" = "1.12.0" ]; then
|
|
# Workaround for building with apr-1.7.0:
|
|
export svn_cv_pycfmt_apr_int64_t="L"
|
|
fi
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--with-apache-libexecdir=/usr/lib${LIBDIRSUFFIX}/httpd/modules \
|
|
--mandir=/usr/man \
|
|
--docdir=/usr/doc/subversion-$VERSION \
|
|
--enable-shared \
|
|
--disable-static \
|
|
--with-apr=/usr \
|
|
--with-apr-util=/usr \
|
|
--with-apxs=/usr/bin/apxs \
|
|
--with-lz4=/usr \
|
|
--with-zlib=/usr \
|
|
--with-pic \
|
|
--with-kwallet \
|
|
--with-gnome-keyring \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make $NUMJOBS install DESTDIR=$PKG || exit 1
|
|
make $NUMJOBS install-tools DESTDIR=$PKG || exit 1
|
|
make $NUMJOBS install-docs DESTDIR=$PKG || exit 1
|
|
|
|
## COMMENTED OUT - this doesn't work with swig > 4.0.0
|
|
## If something actually needs it, let me know and I'll look at it again.
|
|
## Install python bindings
|
|
#make swig-py || exit 1
|
|
#make install-swig-py DESTDIR=$PKG || exit 1
|
|
#PYTHON_VER=$(python3 -c 'import sys; print "%d.%d" % sys.version_info[:2]')
|
|
#mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/python${PYTHON_VER}/site-packages
|
|
#mv $PKG/usr/lib${LIBDIRSUFFIX}/svn-python/* \
|
|
# $PKG/usr/lib${LIBDIRSUFFIX}/python${PYTHON_VER}/site-packages
|
|
#rmdir $PKG/usr/lib${LIBDIRSUFFIX}/svn-python
|
|
|
|
# Perl bindings
|
|
make $NUMJOBS swig-pl-lib || exit 1
|
|
make install-swig-pl-lib DESTDIR=$PKG || exit 1
|
|
( cd subversion/bindings/swig/perl/native
|
|
perl Makefile.PL
|
|
make $NUMJOBS install_vendor DESTDIR=$PKG || exit 1
|
|
) || exit 1
|
|
eval $(perl '-V:archlib')
|
|
mv $PKG/$archlib/perllocal.pod $PKG/$archlib/subversion.pod
|
|
|
|
# Ruby bindings
|
|
make $NUMJOBS swig-rb || exit 1
|
|
make $NUMJOBS install-swig-rb DESTDIR=$PKG || exit 1
|
|
|
|
# Don't ship .la files:
|
|
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Remove rpaths:
|
|
for file in $(find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : 2> /dev/null) ; do
|
|
if [ ! "$(patchelf --print-rpath $file 2> /dev/null)" = "" ]; then
|
|
patchelf --remove-rpath $file
|
|
fi
|
|
done
|
|
|
|
rm -rf $PKG/usr/info
|
|
# Something doesn't honor --mandir
|
|
mv $PKG/usr/share/man/man3 $PKG/usr/man
|
|
gzip -9 $PKG/usr/man/man?/*
|
|
rmdir $PKG/usr/share/man
|
|
|
|
# What is this junk for? Since I don't know, I'll erase it. :-)
|
|
rm -rf $PKG/usr/build
|
|
|
|
mkdir -p $PKG/usr/doc/subversion-$VERSION
|
|
cp -a \
|
|
BUGS COMMITTERS COPYING* HACKING INSTALL README TRANSLATING doc \
|
|
$PKG/usr/doc/subversion-$VERSION
|
|
# too big && useless for most || if you think not, can be found in the source tarball
|
|
rm -rf $PKG/usr/doc/subversion-$VERSION/doc/tools
|
|
# Add the HTML svn book:
|
|
( cd $PKG/usr/doc/subversion-$VERSION
|
|
tar xf $CWD/svn-book-html.tar.bz2
|
|
mv svn-book-html book
|
|
cd book
|
|
chown -R root:root .
|
|
find . -type d -exec chmod 0755 {} \+
|
|
find . -type f -exec chmod 0644 {} \+
|
|
find . -perm 2755 -exec chmod 0755 {} \+
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
)
|
|
|
|
# If there's a CHANGES file, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r CHANGES ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat CHANGES | head -n 1000 > $DOCSDIR/CHANGES
|
|
touch -r CHANGES $DOCSDIR/CHANGES
|
|
fi
|
|
|
|
# This removes our DESTDIR from the packlist filenames, to keep perl's
|
|
# internal inventories consistent and correct.
|
|
find $PKG -name .packlist | while read plist ; do
|
|
sed -e "s%$PKG%%g" \
|
|
-e "s%/share/man%/man%g" \
|
|
-re "s%\.([1-9]n?|3pm)$%&.gz%g # extend man filenames for .gz" \
|
|
${plist} > ${plist}.new
|
|
mv -f ${plist}.new ${plist}
|
|
done
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/subversion-$VERSION-$ARCH-$BUILD.txz
|
|
|