mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
673e345487
a/hostname-3.25-x86_64-1.txz: Upgraded. d/ninja-1.12.1-x86_64-2.txz: Rebuilt. Generate and include manual.html. d/perl-5.40.0-x86_64-2.txz: Rebuilt. Upgraded: DBI-1.645, IO-Socket-SSL-2.089, Template-Toolkit-3.102, URI-5.30. Added: Path-Tiny-0.146. (Needed by Moo, thanks to Andypoo) kde/fcitx5-configtool-5.1.7-x86_64-1.txz: Upgraded. l/python-sphinx-8.1.1-x86_64-1.txz: Upgraded. l/python-trove-classifiers-2024.10.12-x86_64-1.txz: Upgraded. l/qt6-6.7.3_20240920_90e86aee-x86_64-1.txz: Upgraded. x/wayland-protocols-1.38-noarch-1.txz: Upgraded.
131 lines
4.3 KiB
Bash
Executable file
131 lines
4.3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2016, 2017 Eric Hameleers, Eindhoven, NL
|
|
# Copyright 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=ninja
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-2}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$(uname -m)" in
|
|
i?86) ARCH=i686 ;;
|
|
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) ARCH=$(uname -m) ;;
|
|
esac
|
|
export ARCH
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
SLKLDFLAGS="-L/usr/lib64"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
SLKLDFLAGS=""
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
case "$ARCH" in
|
|
arm*) TARGET=$ARCH-slackware-linux-gnueabi ;;
|
|
*) TARGET=$ARCH-slackware-linux ;;
|
|
esac
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
|
|
cd $PKGNAM-$VERSION || exit 1
|
|
|
|
# Fix bogus permissions:
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Build the program:
|
|
LDFLAGS="$SLKLDFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS" \
|
|
CFLAGS="$SLKCFLAGS" \
|
|
python3 configure.py --bootstrap || exit 1
|
|
|
|
# Manually install stuff:
|
|
install -D -m0755 ninja $PKG/usr/bin/ninja || exit 1
|
|
install -D -m0644 misc/bash-completion $PKG/usr/share/bash-completion/completions/ninja || exit 1
|
|
install -D -m0644 misc/zsh-completion $PKG/usr/share/zsh/site-functions/_ninja || exit 1
|
|
install -D -m0644 misc/ninja.vim $PKG/usr/share/vim/vimfiles/syntax/ninja.vim || exit 1
|
|
install -D -m0644 misc/ninja-mode.el $PKG/usr/share/emacs/site-lisp/ninja-mode.el || exit 1
|
|
|
|
# Compiling the .el should be optional...
|
|
#emacs -Q --batch -f batch-byte-compile misc/ninja-mode.el || exit 1
|
|
#install -D -m0644 misc/ninja-mode.elc $PKG/usr/share/emacs/site-lisp/ninja-mode.elc || exit 1
|
|
|
|
# Compress the man page(s):
|
|
if [ -d $PKG/usr/man ]; then
|
|
find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \+
|
|
for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
|
fi
|
|
|
|
# Strip binaries (if any):
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
# Build HTML manual:
|
|
ninja manual doc/manual.html
|
|
|
|
# Add documentation:
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a \
|
|
COPYING* HACKING* README* RELEASING \
|
|
doc/manual.html \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
# Add a package description:
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|