slackware-current/source/d/indent/indent.SlackBuild
Patrick J Volkerding 6b6caf66ba Tue Mar 21 21:18:59 UTC 2023
a/elilo-3.16-x86_64-15.txz:  Rebuilt.
  eliloconfig: drop support for old EFI vars interface.
  Mount efivarfs on /sys/firmware/efi/efivars if we find that the directory
  is empty.
d/indent-2.2.13-x86_64-1.txz:  Upgraded.
d/scons-4.5.2-x86_64-1.txz:  Upgraded.
x/libva-2.18.0-x86_64-1.txz:  Upgraded.
xap/mozilla-firefox-111.0.1-x86_64-1.txz:  Upgraded.
  This is a bugfix release.
  For more information, see:
    https://www.mozilla.org/en-US/firefox/111.0.1/releasenotes/
xfce/xfce4-clipman-plugin-1.6.3-x86_64-1.txz:  Upgraded.
extra/tigervnc/tigervnc-1.13.1-x86_64-1.txz:  Upgraded.
isolinux/initrd.img:  Rebuilt.
  Make sure efivarfs is mounted on UEFI systems.
usb-and-pxe-installers/usbboot.img:  Rebuilt.
  Make sure efivarfs is mounted on UEFI systems.
2023-03-21 23:41:13 +01:00

130 lines
3.9 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2010, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=indent
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
else
SLKCFLAGS="-O2"
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
PKG=$TMP/package-indent
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf indent-$VERSION
tar xvf $CWD/indent-$VERSION.tar.?z || exit 1
cd indent-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# GCC4 fix
#sed -i -e 's#extern FILE \*output#static FILE *output#' src/indent.h || exit 1
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
## I'm not sure why this man page fails, but...
#if find $PKG -type f -size 0c -name indent.1 ; then
# ( cd man
# ./texinfo2man ./indent.1.in ./../doc/indent.texinfo > indent.1
# cat indent.1 > $PKG/usr/man/man1/indent.1
# )
#fi
# Strip binaries and libraries:
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress man pages:
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \+
for i in $( find . -type l ) ; do
ln -s $( readlink $i ).gz $i.gz ; rm $i
done
)
# Compress info pages and remove the package's dir file:
rm -f $PKG/usr/info/dir
gzip -9 $PKG/usr/info/*.info*
# Copy program documentation into the package:
mkdir -p $PKG/usr/doc/indent-$VERSION
cp -a \
AUTHORS COPYING* NEWS README \
$PKG/usr/doc/indent-$VERSION
chmod 644 $PKG/usr/doc/indent-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
# Build the package:
cd $PKG
/sbin/makepkg -l y -c n $TMP/indent-$VERSION-$ARCH-$BUILD.txz