slackware-current/source/d/icecream/icecream.SlackBuild
Patrick J Volkerding 7354944bf0 Mon Nov 21 20:23:13 UTC 2022
a/libpwquality-1.4.5-x86_64-1.txz:  Upgraded.
a/pciutils-3.9.0-x86_64-1.txz:  Upgraded.
ap/qpdf-11.2.0-x86_64-1.txz:  Upgraded.
d/mercurial-6.3.1-x86_64-1.txz:  Upgraded.
kde/krusader-2.8.0-x86_64-1.txz:  Upgraded.
l/libpng-1.6.39-x86_64-1.txz:  Upgraded.
l/mlt-7.12.0-x86_64-1.txz:  Upgraded.
x/fcitx5-5.0.20-x86_64-1.txz:  Upgraded.
x/fcitx5-anthy-5.0.13-x86_64-1.txz:  Upgraded.
x/fcitx5-chinese-addons-5.0.16-x86_64-1.txz:  Upgraded.
x/fcitx5-gtk-5.0.20-x86_64-1.txz:  Upgraded.
x/fcitx5-kkc-5.0.11-x86_64-1.txz:  Upgraded.
x/fcitx5-m17n-5.0.11-x86_64-1.txz:  Upgraded.
x/fcitx5-qt-5.0.16-x86_64-1.txz:  Upgraded.
x/fcitx5-table-extra-5.0.12-x86_64-1.txz:  Upgraded.
x/fcitx5-unikey-5.0.12-x86_64-1.txz:  Upgraded.
x/libXdmcp-1.1.4-x86_64-1.txz:  Upgraded.
x/libXpm-3.5.14-x86_64-1.txz:  Upgraded.
x/libXrandr-1.5.3-x86_64-1.txz:  Upgraded.
x/libime-1.0.15-x86_64-1.txz:  Upgraded.
x/libinput-1.22.0-x86_64-1.txz:  Upgraded.
x/xcb-imdkit-1.0.4-x86_64-1.txz:  Upgraded.
2022-11-22 07:00:14 +01:00

138 lines
4.1 KiB
Bash
Executable file

#!/bin/sh
# Copyright 2009-2018 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2018, 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=icecream
SRCNAM=icecc
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
OUTPUT=${OUTPUT:-$TMP}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.lz || exit 1
cd $SRCNAM-$VERSION || exit 1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#./autogen.sh || exit 1
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib$LIBDIRSUFFIX \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--enable-clang-rewrite-includes \
--enable-clang-wrappers \
--enable-shared \
--disable-static \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install-strip DESTDIR=$PKG || exit 1
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
mkdir -p $PKG/etc/profile.d/
cp -a $CWD/icecream.{csh,sh} $PKG/etc/profile.d/
chown root:root $PKG/etc/profile.d/*
chmod 755 $PKG/etc/profile.d/*
# Install init scripts and config file:
mkdir -p $PKG/etc/rc.d
cp -a $CWD/rc.iceccd $PKG/etc/rc.d/rc.iceccd.new
cp -a $CWD/rc.icecc-scheduler $PKG/etc/rc.d/rc.icecc-scheduler.new
cp -a $CWD/rc.icecream.conf $PKG/etc/rc.d/rc.icecream.conf.new
chown root:root $PKG/etc/rc.d/*
chmod 644 $PKG/etc/rc.d/*
# Add Slackware compiler symlinks:
for i in $ARCH-slackware-linux-c++ $ARCH-slackware-linux-g++ \
$ARCH-slackware-linux-gcc $ARCH-slackware-linux-clang \
$ARCH-slackware-linux-clang++; do
ln -s /usr/bin/icecc $PKG/usr/libexec/icecc/bin/$i
done
mkdir -p $PKG/var/{cache,log}/icecream
chown icecc:icecc $PKG/var/{cache,log}/icecream
find $PKG/usr/man -type f -exec gzip -9 {} \+
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
BENCH* COPYING* NEWS* README* TODO* \
$PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PKGNAM-$VERSION-$ARCH-$BUILD.txz