mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
054967ebe9
a/cracklib-2.10.2-x86_64-1.txz: Upgraded. ap/ksh93-1.0.10-x86_64-1.txz: Upgraded. ap/nvme-cli-2.10.2-x86_64-1.txz: Upgraded. d/Cython-3.0.11-x86_64-1.txz: Upgraded. d/binutils-2.43-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/cmake-3.30.2-x86_64-1.txz: Upgraded. Recompiled against binutils-2.43. d/oprofile-1.4.0-x86_64-14.txz: Rebuilt. kde/calligra-3.2.1-x86_64-43.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/cantor-23.08.5-x86_64-9.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kfilemetadata-5.116.0-x86_64-5.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kile-2.9.93-x86_64-36.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kitinerary-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/krita-5.2.3-x86_64-3.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kstars-3.7.2-x86_64-1.txz: Upgraded. kde/labplot-2.11.1-x86_64-2.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/libindi-2.0.9-x86_64-1.txz: Upgraded. kde/okular-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. l/SDL2-2.30.6-x86_64-1.txz: Upgraded. l/abseil-cpp-20240722.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/ffmpeg-6.1.2-x86_64-1.txz: Upgraded. This is a temporary improvment. ;-) l/fluidsynth-2.3.6-x86_64-1.txz: Upgraded. l/libdeflate-1.21-x86_64-1.txz: Upgraded. l/libnvme-1.10-x86_64-1.txz: Upgraded. l/mozilla-nss-3.103-x86_64-1.txz: Upgraded. l/mozjs115-115.14.0esr-x86_64-1.txz: Upgraded. l/poppler-24.08.0-x86_64-2.txz: Rebuilt. Shared library .so-version bump. l/protobuf-27.3-x86_64-2.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. l/python-wheel-0.44.0-x86_64-1.txz: Upgraded. l/readline-8.2.013-x86_64-1.txz: Upgraded. n/c-ares-1.33.0-x86_64-1.txz: Upgraded. n/mosh-1.4.0-x86_64-3.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. x/libFS-1.0.10-x86_64-1.txz: Upgraded. x/libXfont2-2.0.7-x86_64-1.txz: Upgraded. x/libXtst-1.2.5-x86_64-1.txz: Upgraded. x/x11perf-1.7.0-x86_64-1.txz: Upgraded. xap/pavucontrol-6.1-x86_64-1.txz: Upgraded.
91 lines
3.1 KiB
Bash
Executable file
91 lines
3.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2015 Robby Workman, Tuscaloosa, Alabama, USA
|
|
# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=Cython
|
|
SRCNAM=cython
|
|
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) ARCH=i686 ;;
|
|
arm*) ARCH=arm ;;
|
|
*) ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
rm -rf $SRCNAM-$VERSION
|
|
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z || exit 1
|
|
cd $SRCNAM-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find -L . \
|
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
unshare -n python3 -m build --wheel --no-isolation || exit 1
|
|
|
|
python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
|
|
|
|
# Make cython3 symlink:
|
|
if [ ! -x $PKG/usr/bin/cython3 ]; then
|
|
( cd $PKG/usr/bin ; ln -sf cython cython3)
|
|
fi
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
cp -a *.rst *.txt docs/* $PKG/usr/doc/$PKGNAM-$VERSION
|
|
|
|
# If there's a CHANGES.rst, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r CHANGES.rst ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat CHANGES.rst | head -n 1000 > $DOCSDIR/CHANGES.rst
|
|
touch -r CHANGES.rst $DOCSDIR/CHANGES.rst
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|