slackware-current/source/ap/xmltoman/xmltoman.SlackBuild
Patrick J Volkerding 6a20480259 Fri Feb 23 02:27:35 UTC 2024
a/aaa_libraries-15.1-x86_64-26.txz:  Rebuilt.
  Upgraded: libacl.so.1.1.2302, libattr.so.1.1.2502, liblzma.so.5.4.6,
  libpcre2-8.so.0.12.0, libz.so.1.3.1, libcares.so.2.11.0,
  libexpat.so.1.9.0, libffi.so.8.1.4, libglib-2.0.so.0.7800.4,
  libgmodule-2.0.so.0.7800.4, libgobject-2.0.so.0.7800.4,
  libgthread-2.0.so.0.7800.4, libidn.so.12.6.5, libidn2.so.0.4.0,
  libpng16.so.16.41.0, libpsl.so.5.3.5, libtdb.so.1.4.10, libusb-1.0.so.0.4.0.
a/etc-15.1-x86_64-5.txz:  Rebuilt.
  Added UID 214 and GID 214 for avahi.
a/gettext-0.22.5-x86_64-1.txz:  Upgraded.
a/pkgtools-15.1-noarch-9.txz:  Rebuilt.
  setup.services: support rc.avahidaemon and rc.avahidnsconfd.
a/sysvinit-scripts-15.1-noarch-13.txz:  Rebuilt.
  rc.M: start (if executable) rc.avahidaemon and rc.avahidnsconfd.
ap/cups-2.4.7-x86_64-2.txz:  Rebuilt.
  Recompiled against avahi.
ap/cups-filters-1.28.17-x86_64-4.txz:  Rebuilt.
  Recompiled against avahi.
ap/hplip-3.23.12-x86_64-1.txz:  Upgraded.
  Compiled against avahi.
ap/xmltoman-0.6-x86_64-1.txz:  Added.
  This is needed to generate manpages for avahi.
d/distcc-3.4-x86_64-4.txz:  Rebuilt.
  Recompiled against avahi.
d/gettext-tools-0.22.5-x86_64-1.txz:  Upgraded.
l/avahi-20240220_dffd549-x86_64-1.txz:  Added.
  It was either this, or drop (or fork) hplip. We'll enjoy it in the long run.
  Thanks to David Somero for the original build script, and to Robby Workman
  for years of maintenance.
  Signed-off-by: volkerdi
  Acked-by: alienBOB
l/libdaemon-0.14-x86_64-1.txz:  Added.
  This is needed by avahi.
l/pipewire-1.0.3-x86_64-5.txz:  Rebuilt.
  Recompiled against avahi.
l/pulseaudio-17.0-x86_64-3.txz:  Rebuilt.
  Recompiled against avahi.
n/NetworkManager-1.46.0-x86_64-1.txz:  Upgraded.
n/netatalk-3.1.18-x86_64-2.txz:  Rebuilt.
  Recompiled against avahi.
n/samba-4.19.5-x86_64-2.txz:  Rebuilt.
  Recompiled against avahi.
xap/pidgin-2.14.12-x86_64-3.txz:  Rebuilt.
  Recompiled against avahi.
xap/sane-1.2.1-x86_64-3.txz:  Rebuilt.
  Recompiled against avahi.
extra/bash-completion/bash-completion-2.12.0-noarch-1.txz:  Upgraded.
2024-02-23 03:58:34 +01:00

119 lines
3.7 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=xmltoman
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i586 ;;
arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "armv7hl" ]; then
SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
LIBDIRSUFFIX=""
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
sed -i "s|prefix=/usr/local|prefix=/usr|g" Makefile
sed -i "s|share/man|man|g" Makefile
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
COPYING* ChangeLog LICENSE* README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz