slackware-current/source/ap/xfsdump/xfsdump.SlackBuild
Patrick J Volkerding 7ff3810884 Tue Sep 3 21:07:09 UTC 2024
a/cryptsetup-2.7.5-x86_64-1.txz:  Upgraded.
a/kernel-firmware-20240903_7a7a88f-noarch-1.txz:  Upgraded.
a/openssl-solibs-3.3.2-x86_64-1.txz:  Upgraded.
ap/xfsdump-3.2.0-x86_64-1.txz:  Upgraded.
d/opencl-headers-2024.05.08-noarch-1.txz:  Upgraded.
d/ruby-3.3.5-x86_64-1.txz:  Upgraded.
l/mozjs115-115.15.0esr-x86_64-1.txz:  Upgraded.
n/openssl-3.3.2-x86_64-1.txz:  Upgraded.
  This update fixes bugs and security issues:
  Fixed possible denial of service in X.509 name checks.
  Fixed possible buffer overread in SSL_select_next_proto().
  For more information, see:
    https://openssl-library.org/news/secadv/20240903.txt
    https://openssl-library.org/news/secadv/20240627.txt
    https://www.cve.org/CVERecord?id=CVE-2024-6119
    https://www.cve.org/CVERecord?id=CVE-2024-5535
  (* Security fix *)
n/samba-4.21.0-x86_64-1.txz:  Upgraded.
x/libevdev-1.13.3-x86_64-1.txz:  Upgraded.
x/xterm-394-x86_64-1.txz:  Upgraded.
xap/mozilla-firefox-128.2.0esr-x86_64-1.txz:  Upgraded.
  This update contains security fixes and improvements.
  For more information, see:
    https://www.mozilla.org/en-US/firefox/128.2.0/releasenotes/
    https://www.mozilla.org/security/advisories/mfsa2024-40/
    https://www.cve.org/CVERecord?id=CVE-2024-8385
    https://www.cve.org/CVERecord?id=CVE-2024-8381
    https://www.cve.org/CVERecord?id=CVE-2024-8382
    https://www.cve.org/CVERecord?id=CVE-2024-8383
    https://www.cve.org/CVERecord?id=CVE-2024-8384
    https://www.cve.org/CVERecord?id=CVE-2024-8386
    https://www.cve.org/CVERecord?id=CVE-2024-8387
  (* Security fix *)
xap/seamonkey-2.53.19-x86_64-1.txz:  Upgraded.
  This update contains security fixes and improvements.
  For more information, see:
    https://www.seamonkey-project.org/releases/seamonkey2.53.19
  (* Security fix *)
2024-09-04 00:33:23 +02:00

133 lines
4.1 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2010, 2013, 2015, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=xfsdump
VERSION=${VERSION:-$(echo xfsdump-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i686 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$(echo $VERSION | tr - _ )-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-xfsdump
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf xfsdump-$(echo $VERSION | cut -f 1 -d '-')
tar xvf $CWD/xfsdump-$VERSION.tar.?z || exit 1
cd xfsdump-$(echo $VERSION | cut -f 1 -d '-') || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Make sure you have the same version of autoconf as the
# developers did... ;-)
#autoreconf -vif
./configure \
--prefix=/usr \
--sbindir=/usr/sbin \
--bindir=/usr/sbin \
--enable-gettext=yes \
--mandir=/usr/man \
--datadir=/usr/share \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
( cd $PKG/usr/sbin
rm -f xfsdump xfsrestore
ln -sf /sbin/xfsdump xfsdump
ln -sf /sbin/xfsrestore xfsrestore
)
# Strip libraries:
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and if needed symlink the man pages:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
mv $PKG/usr/share/doc $PKG/usr
( cd $PKG/usr/doc ; mv xfsdump xfsdump-$VERSION )
cp -a \
README doc/COPYING doc/CREDITS doc/PORTING \
$PKG/usr/doc/xfsdump-$VERSION
mkdir -p $PKG/usr/doc/xfsdump-$VERSION/html
( cd doc
cp -a *.gif *.html $PKG/usr/doc/xfsdump-$VERSION/html
)
rm -f $PKG/usr/doc/xfsdump-$VERSION/CHANGES.gz
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r doc/CHANGES ]; then
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
cat doc/CHANGES | head -n 1000 > $DOCSDIR/CHANGES
touch -r doc/CHANGES $DOCSDIR/CHANGES
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/xfsdump-$(echo $VERSION | tr - _ )-$ARCH-$BUILD.txz