mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
07449d94af
a/kernel-generic-6.10.9-x86_64-1.txz: Upgraded. a/kernel-huge-6.10.9-x86_64-1.txz: Upgraded. a/kernel-modules-6.10.9-x86_64-1.txz: Upgraded. ap/texinfo-7.1.1-x86_64-1.txz: Upgraded. d/kernel-headers-6.10.9-x86-1.txz: Upgraded. d/python3-3.11.10-x86_64-1.txz: Upgraded. This update fixes security issues: Bundled libexpat was updated to 2.6.3. Fix quadratic complexity in parsing "-quoted cookie values with backslashes by http.cookies. Fixed various false positives and false negatives in IPv4Address.is_private, IPv4Address.is_global, IPv6Address.is_private, IPv6Address.is_global. Fix urllib.parse.urlunparse() and urllib.parse.urlunsplit() for URIs with path starting with multiple slashes and no authority. Remove backtracking from tarfile header parsing for hdrcharset, PAX, and GNU sparse headers. email.utils.getaddresses() and email.utils.parseaddr() now return ('', '') 2-tuples in more situations where invalid email addresses are encountered instead of potentially inaccurate values. Add optional strict parameter to these two functions: use strict=False to get the old behavior, accept malformed inputs. getattr(email.utils, 'supports_strict_parsing', False) can be used to check if the strict paramater is available. Sanitize names in zipfile.Path to avoid infinite loops (gh-122905) without breaking contents using legitimate characters. Email headers with embedded newlines are now quoted on output. The generator will now refuse to serialize (write) headers that are unsafely folded or delimited; see verify_generated_headers. For more information, see: https://pythoninsider.blogspot.com/2024/09/python-3130rc2-3126-31110-31015-3920.html https://www.cve.org/CVERecord?id=CVE-2024-28757 https://www.cve.org/CVERecord?id=CVE-2024-45490 https://www.cve.org/CVERecord?id=CVE-2024-45491 https://www.cve.org/CVERecord?id=CVE-2024-45492 https://www.cve.org/CVERecord?id=CVE-2024-7592 https://www.cve.org/CVERecord?id=CVE-2024-4032 https://www.cve.org/CVERecord?id=CVE-2015-2104 https://www.cve.org/CVERecord?id=CVE-2024-6232 https://www.cve.org/CVERecord?id=CVE-2023-27043 https://www.cve.org/CVERecord?id=CVE-2024-8088 https://www.cve.org/CVERecord?id=CVE-2024-6923 (* Security fix *) k/kernel-source-6.10.9-noarch-1.txz: Upgraded. TEE n -> m +AMDTEE m +AMD_PMF m +AMD_PMF_DEBUG n Thanks to nick8325 for the suggestion. l/qt5-5.15.15_20240903_363456a6-x86_64-1.txz: Upgraded. x/noto-emoji-2.042-noarch-1.txz: Added. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
142 lines
4.7 KiB
Bash
Executable file
142 lines
4.7 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2008, 2009, 2010, 2016, 2018, 2019, 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=texinfo
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# Don't use icecream:
|
|
PATH=$(echo $PATH | sed "s|/usr/libexec/icecc/bin||g" | tr -s : | sed "s/^://g" | sed "s/:$//g")
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-texinfo
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
tar xvf $CWD/texinfo-$VERSION.tar.xz || exit 1
|
|
cd texinfo-$VERSION || exit 1
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# The --disable-perl-xs below prevents some perl extensions from being replaced
|
|
# by C versions which have been known to choke over UTF-8 issues:
|
|
# NOTE (12/2022): Removed this option to get a2ps building again. Looks like
|
|
# Arch (at least) does not include this option either.
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--docdir=/usr/doc/texinfo-$VERSION \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
# Don't run this - it falls over with perl-5.38.0:
|
|
#make update-po || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
gzip -9 $PKG/usr/info/*info*
|
|
gzip -9 $PKG/usr/man/man?/*
|
|
|
|
# Add update-info-dir script and manpage originally from Debian:
|
|
mkdir -p $PKG/usr/sbin
|
|
cp -a $CWD/update-info-dir.gz $PKG/usr/sbin
|
|
gzip -d $PKG/usr/sbin/update-info-dir.gz
|
|
chown root:root $PKG/usr/sbin/update-info-dir
|
|
chmod 755 $PKG/usr/sbin/update-info-dir
|
|
mkdir -p $PKG/usr/man/man8
|
|
cp -a $CWD/update-info-dir.8.gz $PKG/usr/man/man8
|
|
chown root:root $PKG/usr/man/man8/update-info-dir.8.gz
|
|
chmod 644 $PKG/usr/man/man8/update-info-dir.8.gz
|
|
|
|
# Eliminate stale /usr/info/dir:
|
|
rm -f $PKG/usr/info/dir
|
|
|
|
# Run update-info-dir to get a current /usr/info/dir, then install it into the
|
|
# package as .new:
|
|
sh $PKG/usr/sbin/update-info-dir
|
|
cp -a /usr/info/dir $PKG/usr/info/dir.new
|
|
|
|
mkdir -p $PKG/usr/doc/texinfo-$VERSION
|
|
cp -a \
|
|
ABOUT-NLS AUTHORS COPYING* INSTALL INTRODUCTION NEWS README* TODO \
|
|
$PKG/usr/doc/texinfo-$VERSION
|
|
chmod 644 $PKG/usr/doc/texinfo-$VERSION/*
|
|
chown -R root:root $PKG/usr/doc/texinfo-$VERSION
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/texinfo-$VERSION-$ARCH-$BUILD.txz
|
|
|