slackware-current/source/ap/squashfs-tools/squashfs-tools.SlackBuild
Patrick J Volkerding 4399af2974 Mon Mar 20 18:26:23 UTC 2023
a/coreutils-9.2-x86_64-1.txz:  Upgraded.
a/elilo-3.16-x86_64-14.txz:  Rebuilt.
  eliloconfig: check first for /sys/firmware/efi/efivars, and then check for
  the older /sys/firmware/efi/vars directory. We should be able to install an
  EFI menu entry if either one is present. Thanks to AlleyTrotter.
a/xz-5.4.2-x86_64-1.txz:  Upgraded.
ap/mpg123-1.31.3-x86_64-1.txz:  Upgraded.
ap/squashfs-tools-4.6-x86_64-1.txz:  Upgraded.
ap/vim-9.0.1418-x86_64-1.txz:  Upgraded.
  Fixed security issues:
  NULL pointer dereference issue in utfc_ptr2len.
  Incorrect Calculation of Buffer Size.
  Heap-based Buffer Overflow.
  Thanks to marav for the heads-up.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-1264
    https://www.cve.org/CVERecord?id=CVE-2023-1175
    https://www.cve.org/CVERecord?id=CVE-2023-1170
  (* Security fix *)
l/imagemagick-7.1.1_4-x86_64-1.txz:  Upgraded.
l/libsigc++-2.12.0-x86_64-1.txz:  Upgraded.
l/netpbm-11.01.01-x86_64-1.txz:  Upgraded.
n/curl-8.0.1-x86_64-1.txz:  Upgraded.
  This update fixes security issues:
  SSH connection too eager reuse still.
  HSTS double-free.
  GSS delegation too eager connection re-use.
  FTP too eager connection reuse.
  SFTP path ~ resolving discrepancy.
  TELNET option IAC injection.
  For more information, see:
    https://curl.se/docs/CVE-2023-27538.html
    https://curl.se/docs/CVE-2023-27537.html
    https://curl.se/docs/CVE-2023-27536.html
    https://curl.se/docs/CVE-2023-27535.html
    https://curl.se/docs/CVE-2023-27534.html
    https://curl.se/docs/CVE-2023-27533.html
    https://www.cve.org/CVERecord?id=CVE-2023-27538
    https://www.cve.org/CVERecord?id=CVE-2023-27537
    https://www.cve.org/CVERecord?id=CVE-2023-27536
    https://www.cve.org/CVERecord?id=CVE-2023-27535
    https://www.cve.org/CVERecord?id=CVE-2023-27534
    https://www.cve.org/CVERecord?id=CVE-2023-27533
  (* Security fix *)
x/fcitx5-gtk-5.0.23-x86_64-1.txz:  Upgraded.
x/libva-utils-2.18.0-x86_64-1.txz:  Upgraded.
xap/vim-gvim-9.0.1418-x86_64-1.txz:  Upgraded.
xfce/xfce4-screensaver-4.18.0-x86_64-1.txz:  Upgraded.
2023-03-20 21:32:56 +01:00

137 lines
4.2 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2015, 2018 Eric Hameleers, Eindhoven, NL
# Copyright 2017, 2018, 2021, 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=squashfs-tools
VERSION=${VERSION:-$( echo squashfs-tools*.tar.?z | cut -d- -f3- | rev | cut -f3- -d . | rev )}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i586 ;;
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -fcommon"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2 -fcommon"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC -fcommon"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "armv7hl" ]; then
SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16 -fcommon"
LIBDIRSUFFIX=""
else
SLKCFLAGS="-O2 -fcommon"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf ${PKGNAM}-${VERSION}
tar xvf $CWD/${PKGNAM}-${VERSION}.tar.?z || exit 1
cd ${PKGNAM}-${VERSION} || exit 1
zcat $CWD/squashfs-tools.glibc228.diff.gz | patch -p1 --verbose || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
cd squashfs-tools || exit 1
# Build:
CFLAGS="$SLKCFLAGS" \
make $NUMJOBS \
GZIP_SUPPORT="1" \
XZ_SUPPORT="1" \
LZ4_SUPPORT="1" \
LZO_SUPPORT="1" \
LZMA_XZ_SUPPORT="1" \
ZSTD_SUPPORT="1" \
COMP_DEFAULT="xz" || exit 1
# Install:
make install INSTALL_DIR=$PKG/usr/bin INSTALL_MANPAGES_DIR=$PKG/usr/man/man1 || exit 1
# Fix (if needed) broken symlinks:
( cd $PKG/usr/bin
if ls -l sqfscat | grep -q package-squashfs-tools ; then
rm sqfscat
ln -sf unsquashfs sqfscat
fi
if ls -l sqfstar | grep -q package-squashfs-tools ; then
rm sqfstar
ln -sf mksquashfs sqfstar
fi
)
# Strip binaries:
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
# Add a documentation directory:
cd ..
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
ACKNOWLEDGEMENTS CHANGES COPYING* INSTALL *README* \
examples/pseudo-file.example \
$PKG/usr/doc/${PKGNAM}-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz