mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
68034e96e4
a/kernel-generic-6.6.17-x86_64-1.txz: Upgraded. a/kernel-huge-6.6.17-x86_64-1.txz: Upgraded. a/kernel-modules-6.6.17-x86_64-1.txz: Upgraded. ap/soma-3.3.7-noarch-3.txz: Rebuilt. Strip trailing whitespace from soma.desktop. Thanks to DryFalls. d/kernel-headers-6.6.17-x86-1.txz: Upgraded. k/kernel-source-6.6.17-noarch-1.txz: Upgraded. l/mozilla-nss-3.98-x86_64-1.txz: Upgraded. n/ca-certificates-20240216-noarch-1.txz: Upgraded. This update provides the latest CA certificates to check for the authenticity of SSL connections. x/ibus-m17n-1.4.28-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
80 lines
2.7 KiB
Bash
Executable file
80 lines
2.7 KiB
Bash
Executable file
#!/bin/sh
|
|
|
|
# Slackware build script for soma
|
|
# (C) 2010 David Woodfall <dave@tty1.uk>
|
|
# Modifications (C) Patrick Volkerding
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PRGNAM=soma
|
|
VERSION=${VERSION:-3.3.7}
|
|
ARCH=noarch
|
|
BUILD=${BUILD:-3}
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-txz}"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PRGNAM
|
|
OUTPUT=${OUTPUT:-$TMP}
|
|
|
|
set -e
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG $OUTPUT
|
|
cd $TMP
|
|
rm -rf $PRGNAM-$VERSION
|
|
tar xfv $CWD/$PRGNAM-$VERSION.tar.gz
|
|
cd $PRGNAM-$VERSION
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
cat $CWD/soma.desktop.strip.trailing.whitespace.diff | patch -p1 || exit 1
|
|
|
|
mkdir -p \
|
|
$PKG/install \
|
|
$PKG/etc/soma/themes \
|
|
$PKG/etc/soma/genres \
|
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
|
|
|
install -m 755 -D soma $PKG/usr/bin/soma
|
|
install -m 644 -D options.conf.new $PKG/etc/soma/
|
|
install -m 644 -D stations.conf.new $PKG/etc/soma/
|
|
install -m 644 -D themes/* $PKG/etc/soma/themes/
|
|
install -m 644 -D genres/* $PKG/etc/soma/genres/
|
|
install -m 644 -D soma.desktop $PKG/usr/share/applications/soma.desktop
|
|
|
|
cp -a README *.txt $PKG/usr/doc/$PRGNAM-$VERSION
|
|
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD.${PKGTYPE:-txz}
|