slackware-current/source/ap/nvme-cli/nvme-cli.SlackBuild
Patrick J Volkerding 054967ebe9 Mon Aug 5 21:58:24 UTC 2024
a/cracklib-2.10.2-x86_64-1.txz:  Upgraded.
ap/ksh93-1.0.10-x86_64-1.txz:  Upgraded.
ap/nvme-cli-2.10.2-x86_64-1.txz:  Upgraded.
d/Cython-3.0.11-x86_64-1.txz:  Upgraded.
d/binutils-2.43-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
d/cmake-3.30.2-x86_64-1.txz:  Upgraded.
  Recompiled against binutils-2.43.
d/oprofile-1.4.0-x86_64-14.txz:  Rebuilt.
kde/calligra-3.2.1-x86_64-43.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/cantor-23.08.5-x86_64-9.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/kfilemetadata-5.116.0-x86_64-5.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/kile-2.9.93-x86_64-36.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/kitinerary-23.08.5-x86_64-7.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/krita-5.2.3-x86_64-3.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/kstars-3.7.2-x86_64-1.txz:  Upgraded.
kde/labplot-2.11.1-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
kde/libindi-2.0.9-x86_64-1.txz:  Upgraded.
kde/okular-23.08.5-x86_64-7.txz:  Rebuilt.
  Recompiled against poppler-24.08.0.
l/SDL2-2.30.6-x86_64-1.txz:  Upgraded.
l/abseil-cpp-20240722.0-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
l/ffmpeg-6.1.2-x86_64-1.txz:  Upgraded.
  This is a temporary improvment. ;-)
l/fluidsynth-2.3.6-x86_64-1.txz:  Upgraded.
l/libdeflate-1.21-x86_64-1.txz:  Upgraded.
l/libnvme-1.10-x86_64-1.txz:  Upgraded.
l/mozilla-nss-3.103-x86_64-1.txz:  Upgraded.
l/mozjs115-115.14.0esr-x86_64-1.txz:  Upgraded.
l/poppler-24.08.0-x86_64-2.txz:  Rebuilt.
  Shared library .so-version bump.
l/protobuf-27.3-x86_64-2.txz:  Rebuilt.
  Recompiled against abseil-cpp-20240722.0.
l/python-wheel-0.44.0-x86_64-1.txz:  Upgraded.
l/readline-8.2.013-x86_64-1.txz:  Upgraded.
n/c-ares-1.33.0-x86_64-1.txz:  Upgraded.
n/mosh-1.4.0-x86_64-3.txz:  Rebuilt.
  Recompiled against abseil-cpp-20240722.0.
x/libFS-1.0.10-x86_64-1.txz:  Upgraded.
x/libXfont2-2.0.7-x86_64-1.txz:  Upgraded.
x/libXtst-1.2.5-x86_64-1.txz:  Upgraded.
x/x11perf-1.7.0-x86_64-1.txz:  Upgraded.
xap/pavucontrol-6.1-x86_64-1.txz:  Upgraded.
2024-08-06 01:03:55 +02:00

133 lines
4 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2020, 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=nvme-cli
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i686 ;;
arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
export ARCH
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
if [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
mkdir meson-build
cd meson-build
meson setup \
--prefix=/usr \
--libdir=lib${LIBDIRSUFFIX} \
--libexecdir=/usr/libexec \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--includedir=/usr/include \
--datadir=/usr/share \
--mandir=/usr/man \
--sysconfdir=/etc \
--localstatedir=/var \
--buildtype=release \
-Ddocs=man \
.. || exit 1
"${NINJA:=ninja}" $NUMJOBS || exit 1
DESTDIR=$PKG $NINJA install || exit 1
cd ..
# Make discovery.conf file .new:
mv $PKG/etc/nvme/discovery.conf $PKG/etc/nvme/discovery.conf.new
# Remove dracut and systemd libdir files:
rm -r $PKG/usr/lib/{dracut,systemd,udev}
rmdir $PKG/usr/lib 2> /dev/null
# Move man pages:
mv $PKG/usr/share/man $PKG/usr/man
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i
done
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
CONTRIBUTING* LICENSE* README* \
$PKG/usr/doc/${PKGNAM}-$VERSION
mkdir -p $PKG/install
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz