mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
40f1ab9f2a
a/sysklogd-2.6.2-x86_64-1.txz: Upgraded. ap/lxc-6.0.2-x86_64-1.txz: Upgraded. ap/vim-9.1.0736-x86_64-1.txz: Upgraded. l/gjs-1.82.0-x86_64-1.txz: Upgraded. Compiled against mozjs128-128.2.0esr. l/mozjs115-115.15.0esr-x86_64-1.txz: Removed. l/mozjs128-128.2.0esr-x86_64-1.txz: Added. tcl/tcl-8.6.15-x86_64-1.txz: Upgraded. tcl/tk-8.6.15-x86_64-1.txz: Upgraded. xap/vim-gvim-9.1.0736-x86_64-1.txz: Upgraded.
188 lines
6.1 KiB
Bash
Executable file
188 lines
6.1 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2011, 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
# Modified by Matteo Bernardini <ponce@slackbuilds.org> (2014)
|
|
# Modified for LXC 4.0.x by Matthew Chamley <mcgchamley@yahoo.co.uk> (2021)
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=lxc
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | rev | cut -f 2- -d -)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf $PKGNAM-$VERSION
|
|
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
|
|
cd $PKGNAM-$VERSION
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Configure, build, and install:
|
|
export CFLAGS="$SLKCFLAGS"
|
|
export CXXFLAGS="$SLKCFLAGS"
|
|
mkdir meson-build
|
|
cd meson-build
|
|
meson setup \
|
|
--prefix=/usr \
|
|
--libdir=lib${LIBDIRSUFFIX} \
|
|
--libexecdir=/usr/libexec \
|
|
--bindir=/usr/bin \
|
|
--sbindir=/usr/sbin \
|
|
--includedir=/usr/include \
|
|
--datadir=/usr/share \
|
|
--mandir=/usr/man \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--buildtype=release \
|
|
-Ddoc-path=/usr/doc/$PKGNAM-$VERSION \
|
|
-Dglobal-config-path=/etc/lxc \
|
|
-Drootfs-mount-path=/var/lib/rootfs-lxc \
|
|
-Dapparmor=false \
|
|
-Dpam-cgroup=true \
|
|
-Dinit-script=sysvinit \
|
|
.. || exit 1
|
|
"${NINJA:=ninja}" $NUMJOBS || exit 1
|
|
DESTDIR=$PKG $NINJA install || exit 1
|
|
cd ..
|
|
|
|
# The PAM module gets installed in the wrong location and there's no config
|
|
# option to put it in the right place, so we'll do it ourselves:
|
|
mkdir -p $PKG/lib${LIBDIRSUFFIX}
|
|
mv $PKG/usr/lib${LIBDIRSUFFIX}/security $PKG/lib${LIBDIRSUFFIX}
|
|
|
|
# Add the template file:
|
|
cat $CWD/lxc-slackware.in > $PKG/usr/share/lxc/templates/lxc-slackware
|
|
chmod 755 $PKG/usr/share/lxc/templates/lxc-slackware
|
|
|
|
# Make the default configuration directories and an empty rootfs folder:
|
|
mkdir -p $PKG/var/lib/lxc $PKG/etc/lxc $PKG/var/lib/rootfs-lxc $PKG/var/lib/misc
|
|
|
|
# Create a sample default configuration file:
|
|
echo "lxcpath = /var/lib/lxc" > $PKG/etc/lxc/lxc.conf.sample
|
|
|
|
# Move the other config files to .new:
|
|
mv $PKG/etc/lxc/default.conf $PKG/etc/lxc/default.conf.new
|
|
mv $PKG/etc/default/lxc $PKG/etc/default/lxc.new
|
|
|
|
# Install an init script (non executable by default):
|
|
install -D -m 0644 $CWD/rc.lxc $PKG/etc/rc.d/rc.lxc.new
|
|
|
|
# Remove init scripts that we do not use:
|
|
rm -r $PKG/etc/init.d
|
|
|
|
# --disable-static
|
|
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/lib*.a
|
|
|
|
# Strip binaries:
|
|
( cd $PKG
|
|
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
)
|
|
|
|
# Add a documentation directory:
|
|
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
|
|
cp -a \
|
|
AUTHORS* CODING_STYLE* CONTRIBUTING* COPYING* LICENSE* MAINTAINERS* README* \
|
|
doc/FAQ.txt \
|
|
$PKG/usr/doc/${PKGNAM}-$VERSION
|
|
|
|
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION/examples
|
|
cp -a doc/examples/*.conf $PKG/usr/doc/${PKGNAM}-$VERSION/examples
|
|
|
|
# Fix up man pages to stop 'man' from barfing a warning:
|
|
( cd $PKG/usr/man
|
|
grep -F -lr -- '-*- coding: us-ascii -*-' . | xargs sed -i '/-*- coding: us-ascii -*-/d' )
|
|
|
|
# Compress and if needed symlink the man pages:
|
|
if [ -d $PKG/usr/man ]; then
|
|
( cd $PKG/usr/man
|
|
for manpagedir in $(find . -type d -name "man*") ; do
|
|
( cd $manpagedir
|
|
for eachpage in $( find . -type l -maxdepth 1) ; do
|
|
ln -s $( readlink $eachpage ).gz $eachpage.gz
|
|
rm $eachpage
|
|
done
|
|
gzip -9 *.?
|
|
)
|
|
done
|
|
)
|
|
fi
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
# Remove empty documentation files:
|
|
find $PKG/usr/doc/${PKGNAM}-${VERSION} -size 0 -exec rm "{}" \;
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz
|