mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
054967ebe9
a/cracklib-2.10.2-x86_64-1.txz: Upgraded. ap/ksh93-1.0.10-x86_64-1.txz: Upgraded. ap/nvme-cli-2.10.2-x86_64-1.txz: Upgraded. d/Cython-3.0.11-x86_64-1.txz: Upgraded. d/binutils-2.43-x86_64-1.txz: Upgraded. Shared library .so-version bump. d/cmake-3.30.2-x86_64-1.txz: Upgraded. Recompiled against binutils-2.43. d/oprofile-1.4.0-x86_64-14.txz: Rebuilt. kde/calligra-3.2.1-x86_64-43.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/cantor-23.08.5-x86_64-9.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kfilemetadata-5.116.0-x86_64-5.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kile-2.9.93-x86_64-36.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kitinerary-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/krita-5.2.3-x86_64-3.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/kstars-3.7.2-x86_64-1.txz: Upgraded. kde/labplot-2.11.1-x86_64-2.txz: Rebuilt. Recompiled against poppler-24.08.0. kde/libindi-2.0.9-x86_64-1.txz: Upgraded. kde/okular-23.08.5-x86_64-7.txz: Rebuilt. Recompiled against poppler-24.08.0. l/SDL2-2.30.6-x86_64-1.txz: Upgraded. l/abseil-cpp-20240722.0-x86_64-1.txz: Upgraded. Shared library .so-version bump. l/ffmpeg-6.1.2-x86_64-1.txz: Upgraded. This is a temporary improvment. ;-) l/fluidsynth-2.3.6-x86_64-1.txz: Upgraded. l/libdeflate-1.21-x86_64-1.txz: Upgraded. l/libnvme-1.10-x86_64-1.txz: Upgraded. l/mozilla-nss-3.103-x86_64-1.txz: Upgraded. l/mozjs115-115.14.0esr-x86_64-1.txz: Upgraded. l/poppler-24.08.0-x86_64-2.txz: Rebuilt. Shared library .so-version bump. l/protobuf-27.3-x86_64-2.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. l/python-wheel-0.44.0-x86_64-1.txz: Upgraded. l/readline-8.2.013-x86_64-1.txz: Upgraded. n/c-ares-1.33.0-x86_64-1.txz: Upgraded. n/mosh-1.4.0-x86_64-3.txz: Rebuilt. Recompiled against abseil-cpp-20240722.0. x/libFS-1.0.10-x86_64-1.txz: Upgraded. x/libXfont2-2.0.7-x86_64-1.txz: Upgraded. x/libXtst-1.2.5-x86_64-1.txz: Upgraded. x/x11perf-1.7.0-x86_64-1.txz: Upgraded. xap/pavucontrol-6.1-x86_64-1.txz: Upgraded.
174 lines
6.3 KiB
Bash
Executable file
174 lines
6.3 KiB
Bash
Executable file
#!/bin/sh
|
|
# Copyright 2001 BSDi, Inc. Concord, CA, USA
|
|
# Copyright 2004 Slackware Linux, Inc. Concord, CA, USA
|
|
# Copyright 2007, 2008, 2009, 2010, 2013, 2016, 2021, 2022, 2023 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=ksh93
|
|
VERSION=${VERSION:-$(echo ksh-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-$PKGNAM
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
cd $TMP
|
|
|
|
rm -rf ksh-$VERSION
|
|
tar xvf $CWD/ksh-$VERSION.tar.?z || exit 1
|
|
cd ksh-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# ast uses its own architecture labels
|
|
SARCH=$(bin/package host type) || exit
|
|
|
|
CCFLAGS="$SLKCFLAGS" \
|
|
bin/package make || exit
|
|
|
|
mkdir -p $PKG/bin $PKG/usr/bin
|
|
cp arch/$SARCH/bin/ksh $PKG/bin/ksh.new || exit
|
|
cp arch/$SARCH/bin/shcomp $PKG/usr/bin/ || exit
|
|
|
|
# Install ksh93 extra functions:
|
|
mkdir -p $PKG/usr/share/ksh93-functions
|
|
cp -a arch/$SARCH/fun/* $PKG/usr/share/ksh93-functions
|
|
chown root:root $PKG/usr/share/ksh93-functions/*
|
|
chmod 755 $PKG/usr/share/ksh93-functions/*
|
|
|
|
# Add a profile.d script to enable the above functions upon login.
|
|
# This will not be activated by default - to use it, make the script executable
|
|
# (and it will stay that way through future upgrades):
|
|
mkdir -p $PKG/etc/profile.d
|
|
cp -a $CWD/ksh93-functions.sh $PKG/etc/profile.d/ksh93-functions.sh.new
|
|
chown root:root $PKG/etc/profile.d/ksh93-functions.sh.new
|
|
chmod 644 $PKG/etc/profile.d/ksh93-functions.sh.new
|
|
|
|
# this may be re-enabled and updated someday when ksh 93u+m
|
|
# regains the ability to build and use dynamic libraries...
|
|
#cp arch/$SARCH/lib/libshell.so.1.1 /usr/lib
|
|
#cp arch/$SARCH/lib/libshell.a /usr/lib
|
|
#cp arch/$SARCH/lib/libast.so.5.4 /usr/lib
|
|
#cp arch/$SARCH/lib/libast.a /usr/lib
|
|
#cp arch/$SARCH/src/cmd/ksh93/cc-g,-fpic/libshell.so.1.1 /usr/lib
|
|
#cp arch/$SARCH/src/cmd/ksh93/cc-g,-fpic/libshell.a /usr/lib
|
|
#cp arch/$SARCH/src/lib/libast/libast.so.5.4 /usr/lib
|
|
#cp arch/$SARCH/src/cmd/ksh93/cc-g,-fpic/libast.a /usr/lib
|
|
|
|
mkdir -p $PKG/usr/man/man1
|
|
cp src/cmd/ksh93/sh.1 $PKG/usr/man/man1/ksh.1
|
|
LD_LIBRARY_PATH=$PKG/lib $PKG/usr/bin/shcomp --nroff 2> $PKG/usr/man/man1/shcomp.1 || :
|
|
#mkdir -p $PKG/usr/man/man3
|
|
#cp src/cmd/ksh93/shell.3 $PKG/usr/man/man3/
|
|
#cp src/cmd/ksh93/nval.3 $PKG/usr/man/man3/
|
|
( cd $PKG/usr/man/man1 ; ln -sf ksh.1 rksh.1 )
|
|
|
|
# Compress manual pages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz
|
|
rm $i
|
|
done
|
|
|
|
## Install locale files:
|
|
#mkdir -p $PKG/usr/share
|
|
#cp -a share/lib/locale $PKG/usr/share
|
|
#chown -R root:root $PKG/usr/share
|
|
#( cd $PKG/usr/share
|
|
# find . -type d -exec chmod 755 {} \;
|
|
# find . -type f -exec chmod 644 {} \;
|
|
#)
|
|
|
|
#cp src/cmd/ksh93/include/shell.h /usr/include
|
|
|
|
# If anyone is actually using the ksh libraries, drop me some mail
|
|
# and explain which libs you use and what they're for. As it is, I
|
|
# don't see a compeling reason to include them, as ksh itself doesn't
|
|
# use them.
|
|
#( cd /usr/lib ; ln -sf libshell.so.1.1 libshell.so )
|
|
#( cd /usr/lib rm -rf libast.so ; ln -sf libast.so.5.4 libast.so )
|
|
|
|
( cd $PKG/bin ; ln -sf ksh rksh )
|
|
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
|
|
( cd src/cmd/ksh93
|
|
cp -a COMPATIBILITY* DESIGN* OBSOLETE* README* RELEASE* TYPES* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
)
|
|
cp -a ANNOUNCE* CHANGELOG* CONTRIBUTING* COPYRIGHT* LICENSE* NEWS* README* \
|
|
$PKG/usr/doc/$PKGNAM-$VERSION
|
|
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/LICENSES
|
|
cp -a lib/package/LICENSES/* $PKG/usr/doc/$PKGNAM-$VERSION/LICENSES
|
|
find . -name "*.def" -exec cp -a "{}" $PKG/usr/doc/$PKGNAM-$VERSION/LICENSES \;
|
|
find . -name "*.lic" -exec cp -a "{}" $PKG/usr/doc/$PKGNAM-$VERSION/LICENSES \;
|
|
rmdir $PKG/usr/doc/$PKGNAM-$VERSION/LICENSES 2> /dev/null
|
|
chown -R root:root $PKG/usr/doc/$PKGNAM-$VERSION
|
|
find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 644 "{}" \;
|
|
find $PKG/usr/doc/$PKGNAM-$VERSION -type d -exec chmod 755 "{}" \;
|
|
|
|
#chmod 755 $PKG/usr/lib/libshell.so.1.1
|
|
#chmod 755 $PKG/usr/lib/libast.so.5.4
|
|
|
|
# Strip binaries:
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mkdir -p $PKG/install
|
|
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
|