slackware-current/source/ap/ispell/ispell.SlackBuild
Patrick J Volkerding 70006cfdf0 Thu Sep 26 18:28:55 UTC 2024
ap/ispell-3.4.06-x86_64-3.txz:  Rebuilt.
  Get rid of hardcoded temporary path in munchlist.
l/boost-1.86.0-x86_64-2.txz:  Rebuilt.
  Get rid of hardcoded temporary paths in the cmake files.
  Since these paths point to a location that an unprivileged user could
  create and populate with files that could be picked up during a build,
  it's possible this bug could be used for malicious purposes.
  Thanks to jmacloue.
  (* Security fix *)
l/fribidi-1.0.16-x86_64-1.txz:  Upgraded.
n/php-8.3.12-x86_64-1.txz:  Upgraded.
  This update fixes security issues:
  CGI: Fixed bug GHSA-p99j-rfp4-xqvq (Bypass of CVE-2024-4577, Parameter
  Injection Vulnerability).
  CGI: Fixed bug GHSA-94p6-54jq-9mwp (cgi.force_redirect configuration is
  bypassable due to the environment variable collision).
  FPM: Fixed bug GHSA-865w-9rf3-2wh5 (Logs from children may be altered).
  SAPI: Fixed bug GHSA-9pqp-7h25-4f32 (Erroneous parsing of multipart form
  data).
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2024-8926
    https://www.cve.org/CVERecord?id=CVE-2024-8927
    https://www.cve.org/CVERecord?id=CVE-2024-9026
    https://www.cve.org/CVERecord?id=CVE-2024-8925
  (* Security fix *)
x/vulkan-sdk-1.3.290.0-x86_64-2.txz:  Rebuilt.
  Get rid of hardcoded temporary path in volkTargets.cmake.
  (* Security fix *)
2024-09-26 21:02:37 +02:00

124 lines
3.8 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2002-2021 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=ispell
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-3}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-ispell
if [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
else
LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $PKG $PKG
cd $TMP
rm -rf ispell-$VERSION
tar xvf $CWD/ispell-$VERSION.tar.?z || exit 1
cd ispell-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
zcat $CWD/local.h.linux.diff.gz | patch -p1 --verbose || exit 1
sed -i -e "s#/usr/lib/#/usr/lib${LIBDIRSUFFIX}/#" local.h.linux
cp -a local.h.linux local.h
make || exit 1
sleep 2 # to make absolutely sure that config will have a later timestamp
# than local.h and will not get rebuilt by `make install`
sed -i -e "s#/usr#$PKG&#g" config.sh
mkdir -p $PKG/usr/{bin,lib${LIBDIRSUFFIX},man}
make install || exit 1
# Get rid of /tmp/package-ispell path in munchlist:
sed -i "s|/tmp/package-ispell||g" $PKG/usr/bin/munchlist
( cd $PKG/usr/lib${LIBDIRSUFFIX}/ispell
ln -sf americanmed.hash american.hash
ln -sf americanmed.hash english.hash
)
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.*
)
done
)
fi
# Add documentation to the package:
mkdir -p $PKG/usr/doc/ispell-$VERSION
cp -a \
Contributors Magiclines README WISHES \
$PKG/usr/doc/ispell-$VERSION
chown -R root:root $PKG/usr/doc/ispell-$VERSION
# Add the package description:
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
# Make the package:
cd $PKG
/sbin/makepkg -l y -c n $TMP/ispell-$VERSION-$ARCH-$BUILD.txz