mirror of
git://slackware.nl/current.git
synced 2024-12-26 09:58:59 +01:00
8a05a39fd3
a/elogind-255.4_r2-x86_64-1.txz: Upgraded. Prefer SuspendMode=deep. Thanks to LuckyCyborg. Make 10-elogind.conf .new (but it will still be forced in this time). Fix reading login.conf. Thanks to af7567. This branch is feeling a bit alpha to me, but we'll stick with it for now. ap/groff-1.23.0-x86_64-2.txz: Rebuilt. [PATCH] Revert upstream change of mapping special characters for UTF-8. Thanks to Stuart Winter. l/mozjs115-115.10.0esr-x86_64-1.txz: Upgraded. l/python-hatchling-1.24.0-x86_64-1.txz: Upgraded. n/bluez-5.75-x86_64-1.txz: Upgraded. x/libxcb-1.17.0-x86_64-1.txz: Upgraded. xap/mozilla-firefox-115.10.0esr-x86_64-1.txz: Upgraded. This update contains security fixes and improvements. For more information, see: https://www.mozilla.org/en-US/firefox/115.10.0/releasenotes/ https://www.mozilla.org/security/advisories/mfsa2024-19/ https://www.cve.org/CVERecord?id=CVE-2024-3852 https://www.cve.org/CVERecord?id=CVE-2024-3854 https://www.cve.org/CVERecord?id=CVE-2024-3857 https://www.cve.org/CVERecord?id=CVE-2024-2609 https://www.cve.org/CVERecord?id=CVE-2024-3859 https://www.cve.org/CVERecord?id=CVE-2024-3861 https://www.cve.org/CVERecord?id=CVE-2024-3863 https://www.cve.org/CVERecord?id=CVE-2024-3302 https://www.cve.org/CVERecord?id=CVE-2024-3864 (* Security fix *)
155 lines
5 KiB
Bash
Executable file
155 lines
5 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2005-2008, 2009, 2010, 2011, 2016, 2018, 2024 Patrick J. Volkerding, Sebeka, MN, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=groff
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-2}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i586 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-groff
|
|
|
|
if [ "$ARCH" = "i586" ]; then
|
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "s390" ]; then
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
# Don't use icecream:
|
|
PATH=$(echo $PATH | sed "s|/usr/libexec/icecc/bin||g" | tr -s : | sed "s/^://g" | sed "s/:$//g")
|
|
|
|
cd $TMP
|
|
rm -rf groff-$VERSION
|
|
tar xvf $CWD/groff-$VERSION.tar.?z || exit 1
|
|
cd groff-$VERSION || exit 1
|
|
chown -R root:root .
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
# Map special characters to enable unescaped hyphens and other characters
|
|
# in man pages:
|
|
zcat $CWD/0006-Revert-upstream-change-of-mapping-special-characters.patch.gz | patch --verbose -p1 || exit 1
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
CXXFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--with-appresdir=/etc/X11/app-defaults \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--with-x \
|
|
--with-appdefdir=/etc/X11/app-defaults \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
find $PKG | xargs file | grep -e "executable" -e "shared object" \
|
|
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
|
|
|
|
mv $PKG/usr/share/doc $PKG/usr
|
|
cp -a \
|
|
BUG-REPORT COPYING* ChangeLog FDL INSTALL* LICENSE* MANIFEST MORE.STUFF \
|
|
NEWS* PROBLEMS PROJECTS README* REVISION TODO* VERSION \
|
|
$PKG/usr/doc/groff-$VERSION
|
|
mkdir -p $PKG/usr/doc/groff-$VERSION/xditview
|
|
cp -a src/devices/xditview/{README,TODO} $PKG/usr/doc/groff-$VERSION/xditview
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
# If you want all this stuff, it's in the source tarball:
|
|
rm -rf $PKG/usr/doc/groff-$VERSION/*.ps \
|
|
$PKG/usr/doc/groff-$VERSION/examples \
|
|
$PKG/usr/doc/groff-$VERSION/html \
|
|
$PKG/usr/doc/groff-$VERSION/pdf \
|
|
$PKG/usr/doc/groff-$VERSION/groff-man-pages* \
|
|
$PKG/usr/doc/groff-$VERSION/groff.txt
|
|
|
|
( cd $PKG/usr/man
|
|
find . -type f -exec gzip -9 {} \+
|
|
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
|
|
)
|
|
|
|
rm -f $PKG/usr/info/dir
|
|
gzip -9 $PKG/usr/info/*
|
|
|
|
( cd $PKG/usr/bin
|
|
rm -rf geqn ; ln -sf eqn geqn
|
|
rm -rf gindxbib ; ln -sf indxbib gindxbib
|
|
rm -rf gpic ; ln -sf pic gpic
|
|
rm -rf grefer ; ln -sf refer grefer
|
|
rm -rf gsoelim ; ln -sf soelim gsoelim
|
|
rm -rf zsoelim ; ln -sf soelim zsoelim
|
|
rm -rf gtbl ; ln -sf tbl gtbl
|
|
rm -rf gtroff ; ln -sf troff gtroff
|
|
rm -rf glookbib ; ln -sf lookbib glookbib
|
|
rm -rf gnroff ; ln -sf nroff gnroff
|
|
rm -rf gneqn ; ln -sf neqn gneqn
|
|
)
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/groff-$VERSION-$ARCH-$BUILD.txz
|