slackware-current/source/ap/diffutils/diffutils.SlackBuild
Patrick J Volkerding 0eea0f62d2 Tue Aug 3 06:55:27 UTC 2021
a/libcgroup-0.41-x86_64-10.txz:  Rebuilt.
  Added LANG=C to the build script.
ap/diffutils-3.8-x86_64-1.txz:  Upgraded.
d/re2c-2.2-x86_64-1.txz:  Upgraded.
d/rust-1.54.0-x86_64-2.txz:  Rebuilt.
  Move bash completions to /usr/share/bash-completion/completions/.
  Thanks to Robby Workman.
kde/calligra-3.2.1-x86_64-10.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/cantor-21.04.3-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/kfilemetadata-5.84.0-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/kile-2.9.93-x86_64-10.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/kitinerary-21.04.3-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/krita-4.4.5-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
kde/okular-21.04.3-x86_64-2.txz:  Rebuilt.
  Recompiled against poppler-21.08.0.
l/jasper-2.0.33-x86_64-1.txz:  Upgraded.
l/poppler-21.08.0-x86_64-1.txz:  Upgraded.
  Shared library .so-version bump.
l/python-charset-normalizer-2.0.4-x86_64-1.txz:  Upgraded.
n/libmbim-1.26.0-x86_64-1.txz:  Upgraded.
x/libXfont2-2.0.5-x86_64-1.txz:  Upgraded.
x/libXft-2.3.4-x86_64-1.txz:  Upgraded.
x/xeyes-1.2.0-x86_64-1.txz:  Upgraded.
x/xorg-cf-files-1.0.7-x86_64-1.txz:  Upgraded.
x/xwd-1.0.8-x86_64-1.txz:  Upgraded.
xfce/mousepad-0.5.6-x86_64-1.txz:  Upgraded.
2021-08-03 18:00:00 +02:00

136 lines
4.1 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2005-2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=diffutils
VERSION=${VERSION:-$(echo diffutils-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-${PKGNAM}
if [ "$ARCH" = "i386" ]; then
SLKCFLAGS="-O2 -march=i386 -mcpu=i686"
elif [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
else
SLKCFLAGS="-O2"
fi
# Don't use icecream:
PATH=$(echo $PATH | sed "s|/usr/libexec/icecc/bin||g" | tr -s : | sed "s/^://g" | sed "s/:$//g")
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--mandir=/usr/man \
--infodir=/usr/info \
--program-prefix="" \
--program-suffix="" \
--build=$ARCH-slackware-linux || exit 1
make || exit 1
make install DESTDIR=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and if needed symlink the man pages:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
# Compress info pages and purge "dir" file from the package:
if [ -d $PKG/usr/info ]; then
( cd $PKG/usr/info
rm -f dir
gzip -9 *
)
fi
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
AUTHORS COPYING* NEWS README* THANKS TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz