slackware-current/source/a/pciutils/pciutils.SlackBuild
Patrick J Volkerding 7354944bf0 Mon Nov 21 20:23:13 UTC 2022
a/libpwquality-1.4.5-x86_64-1.txz:  Upgraded.
a/pciutils-3.9.0-x86_64-1.txz:  Upgraded.
ap/qpdf-11.2.0-x86_64-1.txz:  Upgraded.
d/mercurial-6.3.1-x86_64-1.txz:  Upgraded.
kde/krusader-2.8.0-x86_64-1.txz:  Upgraded.
l/libpng-1.6.39-x86_64-1.txz:  Upgraded.
l/mlt-7.12.0-x86_64-1.txz:  Upgraded.
x/fcitx5-5.0.20-x86_64-1.txz:  Upgraded.
x/fcitx5-anthy-5.0.13-x86_64-1.txz:  Upgraded.
x/fcitx5-chinese-addons-5.0.16-x86_64-1.txz:  Upgraded.
x/fcitx5-gtk-5.0.20-x86_64-1.txz:  Upgraded.
x/fcitx5-kkc-5.0.11-x86_64-1.txz:  Upgraded.
x/fcitx5-m17n-5.0.11-x86_64-1.txz:  Upgraded.
x/fcitx5-qt-5.0.16-x86_64-1.txz:  Upgraded.
x/fcitx5-table-extra-5.0.12-x86_64-1.txz:  Upgraded.
x/fcitx5-unikey-5.0.12-x86_64-1.txz:  Upgraded.
x/libXdmcp-1.1.4-x86_64-1.txz:  Upgraded.
x/libXpm-3.5.14-x86_64-1.txz:  Upgraded.
x/libXrandr-1.5.3-x86_64-1.txz:  Upgraded.
x/libime-1.0.15-x86_64-1.txz:  Upgraded.
x/libinput-1.22.0-x86_64-1.txz:  Upgraded.
x/xcb-imdkit-1.0.4-x86_64-1.txz:  Upgraded.
2022-11-22 07:00:14 +01:00

156 lines
4.7 KiB
Bash
Executable file

#!/bin/bash
# Copyright 2008, 2009, 2010, 2013, 2015, 2016, 2018, 2022 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=pciutils
VERSION=${VERSION:-$(echo pciutils-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
exit 0
fi
TMP=${TMP:-/tmp}
PKG=$TMP/package-pciutils
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf pciutils-$VERSION
tar xvf $CWD/pciutils-$VERSION.tar.?z || exit 1
cd pciutils-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
zcat $CWD/pciutils.dontcompress.diff.gz | patch -p1 || exit 1
# Build/install the library and utilities:
make clean || exit 1
make install install-lib \
PREFIX=/usr \
SBINDIR=/sbin \
LIBDIR=/usr/lib${LIBDIRSUFFIX} \
MANDIR=/usr/man \
IDSDIR=/usr/share/hwdata \
PCI_IDS=pci.ids \
PCI_COMPRESSED_IDS=0 \
SHARED=yes \
OPT="$SLKCFLAGS" \
DESTDIR=$PKG || exit 1
chmod 755 $PKG/usr/lib${LIBDIRSUFFIX}/libpci.so.*
# Move libraries, as they might be needed by programs that bring a network
# mounted /usr online:
mkdir $PKG/lib${LIBDIRSUFFIX}
( cd $PKG/usr/lib${LIBDIRSUFFIX}
for file in lib*.so.?.* ; do
mv $file ../../lib${LIBDIRSUFFIX}
ln -sf ../../lib${LIBDIRSUFFIX}/$file .
done
cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
)
# Add a symlink to the old location:
if [ ! -x $PKG/sbin/lspci ]; then
if [ -x $PKG/usr/bin/lspci ]; then
( cd $PKG/sbin ; ln -sf ../usr/bin/lspci . )
fi
fi
mkdir -p $PKG/usr/sbin
mv $PKG/sbin/update-pciids $PKG/usr/sbin/update-pciids
# Use pci.ids from hwdata package
rm -f $PKG/usr/share/hwdata/pci.ids
# Remove empty directories:
rmdir $PKG/usr/share/hwdata $PKG/usr/share
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man
for manpagedir in $(find . -type d -name "man*") ; do
( cd $manpagedir
for eachpage in $( find . -type l -maxdepth 1) ; do
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
gzip -9 *.?
)
done
)
fi
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/usr/doc/pciutils-$VERSION
cp -a \
COPYING* README* TODO \
$PKG/usr/doc/pciutils-$VERSION
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
if [ -r ChangeLog ]; then
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
touch -r ChangeLog $DOCSDIR/ChangeLog
fi
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/pciutils-$VERSION-$ARCH-$BUILD.txz