mirror of
git://slackware.nl/current.git
synced 2024-11-16 07:48:02 +01:00
c163a6350b
a/btrfs-progs-6.11-x86_64-1.txz: Upgraded. a/dracut-103-x86_64-1.txz: Added. This is Red Hat's tool to generate an initramfs (aka initrd). Around here, we try not to suffer from Not Invented Here Syndrome (some might say the less we invent, the better ;-). It never hurts to have additional options, and it even looks like our old friend David Cantrell is on the AUTHORS list. I've had good luck here with: dracut --hostonly --force /boot/initrd-6.10.11-generic.img Thanks to Didier Spaier for convincing me to try it out. a/gawk-5.3.1-x86_64-1.txz: Upgraded. a/kernel-generic-6.10.11-x86_64-1.txz: Upgraded. a/upower-1.90.6-x86_64-1.txz: Upgraded. d/kernel-headers-6.10.11-x86-1.txz: Upgraded. k/kernel-source-6.10.11-noarch-1.txz: Upgraded. l/libtiff-4.7.0-x86_64-1.txz: Upgraded. n/curl-8.10.1-x86_64-1.txz: Upgraded. x/mesa-24.2.3-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
154 lines
4.3 KiB
Bash
Executable file
154 lines
4.3 KiB
Bash
Executable file
#!/bin/bash
|
|
|
|
# Copyright 2005-2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
|
|
# All rights reserved.
|
|
#
|
|
# Redistribution and use of this script, with or without modification, is
|
|
# permitted provided that the following conditions are met:
|
|
#
|
|
# 1. Redistributions of this script must retain the above copyright
|
|
# notice, this list of conditions and the following disclaimer.
|
|
#
|
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
|
|
cd $(dirname $0) ; CWD=$(pwd)
|
|
|
|
PKGNAM=gawk
|
|
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
|
|
BUILD=${BUILD:-1}
|
|
|
|
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
|
|
|
|
# Automatically determine the architecture we're building on:
|
|
if [ -z "$ARCH" ]; then
|
|
case "$( uname -m )" in
|
|
i?86) export ARCH=i686 ;;
|
|
arm*) export ARCH=arm ;;
|
|
# Unless $ARCH is already set, use uname -m for all other archs:
|
|
*) export ARCH=$( uname -m ) ;;
|
|
esac
|
|
fi
|
|
|
|
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
|
|
# the name of the created package would be, and then exit. This information
|
|
# could be useful to other scripts.
|
|
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
|
echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
|
|
exit 0
|
|
fi
|
|
|
|
TMP=${TMP:-/tmp}
|
|
PKG=$TMP/package-gawk
|
|
|
|
if [ "$ARCH" = "i686" ]; then
|
|
SLKCFLAGS="-O2 -march=pentium4 -mtune=generic"
|
|
LIBDIRSUFFIX=""
|
|
elif [ "$ARCH" = "x86_64" ]; then
|
|
SLKCFLAGS="-O2 -march=x86-64 -mtune=generic -fPIC"
|
|
LIBDIRSUFFIX="64"
|
|
else
|
|
SLKCFLAGS="-O2"
|
|
LIBDIRSUFFIX=""
|
|
fi
|
|
|
|
# Don't use icecream:
|
|
PATH=$(echo $PATH | sed "s|/usr/libexec/icecc/bin||g" | tr -s : | sed "s/^://g" | sed "s/:$//g")
|
|
|
|
rm -rf $PKG
|
|
mkdir -p $TMP $PKG
|
|
|
|
cd $TMP
|
|
rm -rf gawk-$VERSION
|
|
tar xvf $CWD/gawk-$VERSION.tar.?z || exit 1
|
|
cd gawk-$VERSION || exit 1
|
|
|
|
chown -R root:root .
|
|
|
|
find . \
|
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
|
-exec chmod 755 {} \+ -o \
|
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
|
-exec chmod 644 {} \+
|
|
|
|
CFLAGS="$SLKCFLAGS" \
|
|
./configure \
|
|
--prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
|
--mandir=/usr/man \
|
|
--infodir=/usr/info \
|
|
--build=$ARCH-slackware-linux || exit 1
|
|
|
|
make $NUMJOBS || make || exit 1
|
|
make install DESTDIR=$PKG || exit 1
|
|
|
|
( cd $PKG
|
|
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
|
|
xargs strip --strip-unneeded 2> /dev/null
|
|
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
|
|
xargs strip --strip-unneeded 2> /dev/null
|
|
)
|
|
|
|
( cd $PKG/usr/bin
|
|
ln -sf gawk-$VERSION gawk
|
|
)
|
|
|
|
mkdir -p $PKG/bin
|
|
mv $PKG/usr/bin/gawk* $PKG/bin
|
|
mv $PKG/usr/bin/awk $PKG/bin
|
|
|
|
( cd $PKG/usr/bin
|
|
ln -sf ../../bin/awk .
|
|
ln -sf ../../bin/gawk .
|
|
ln -sf ../../bin/gawk-$VERSION .
|
|
)
|
|
|
|
( cd $PKG/usr/info
|
|
rm dir
|
|
gzip -9 *
|
|
)
|
|
|
|
( cd $PKG/usr/man/man1
|
|
ln -sf gawk.1 awk.1
|
|
)
|
|
|
|
# Compress manual pages:
|
|
find $PKG/usr/man -type f -exec gzip -9 {} \+
|
|
for i in $( find $PKG/usr/man -type l ) ; do
|
|
ln -s $( readlink $i ).gz $i.gz
|
|
rm $i
|
|
done
|
|
|
|
mkdir -p $PKG/usr/doc/gawk-$VERSION
|
|
cp -a \
|
|
ABOUT-NLS AUTHORS COPYING* FUTURES INSTALL LIMITATIONS NEWS POSIX.STD \
|
|
PROBLEMS README* \
|
|
$PKG/usr/doc/gawk-$VERSION
|
|
|
|
# We don't need to run the GPL:
|
|
chmod 644 $PKG/usr/doc/gawk-$VERSION/COPYING*
|
|
|
|
# If there's a ChangeLog, installing at least part of the recent history
|
|
# is useful, but don't let it get totally out of control:
|
|
if [ -r ChangeLog ]; then
|
|
DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
|
|
cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
|
|
touch -r ChangeLog $DOCSDIR/ChangeLog
|
|
fi
|
|
|
|
mkdir -p $PKG/install
|
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
|
|
|
# Build the package:
|
|
cd $PKG
|
|
/sbin/makepkg -l y -c n $TMP/gawk-$VERSION-$ARCH-$BUILD.txz
|
|
|