mirror of
https://github.com/Ponce/slackbuilds
synced 2024-12-10 20:49:31 +01:00
9bd2d4882c
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
33 lines
1 KiB
Diff
33 lines
1 KiB
Diff
diff -Nur 4th-3.64.1/sources/Makefile 4th-3.64.1.new/sources/Makefile
|
|
--- 4th-3.64.1/sources/Makefile 2021-07-25 11:38:40.000000000 +0200
|
|
+++ 4th-3.64.1.new/sources/Makefile 2022-01-20 18:41:25.393103893 +0100
|
|
@@ -13,13 +13,13 @@
|
|
|
|
# The following variables may need to be changed
|
|
|
|
-LIBRARIES=/usr/lib
|
|
-INCLUDES=/usr/include
|
|
-BINARIES=/usr/local/bin
|
|
-MANDIR=/usr/share/man
|
|
-DOCDIR=/usr/share/doc
|
|
+LIBRARIES=$(DESTDIR)/usr/lib$(LIBSUFFIX)
|
|
+INCLUDES=$(DESTDIR)/usr/include
|
|
+BINARIES=$(DESTDIR)/usr/bin
|
|
+MANDIR=$(DESTDIR)/usr/man
|
|
+DOCDIR=$(DESTDIR)/usr/doc
|
|
SOURCES=../4th
|
|
-CFLAGS= -DUNIX -fsigned-char -Wall -O3 -s
|
|
+CFLAGS=$(CXXFLAGS) -DUNIX -fsigned-char -Wall -s
|
|
|
|
# Cross compilation variables
|
|
LD=$(CROSS)ld
|
|
@@ -125,7 +125,8 @@
|
|
|
|
install: mostlyinstall
|
|
install -Dm644 ../documentation/4th.1 $(MANDIR)/man1/4th.1
|
|
- install -Dm644 ../documentation/4tHmanual.txt $(DOCDIR)/4th/
|
|
+ install -Dm644 ../documentation/4tHmanual.pdf $(DOCDIR)/4th-3.64.1/
|
|
+ install -Dm644 ../sources/4th.h $(INCLUDES)/4th.h
|
|
|
|
uninstall:
|
|
-rm -f $(LIBRARIES)/lib4th.{a,so*}
|