slackbuilds_ponce/libraries/wxPython/wxPython-libpng14.diff
2010-05-19 03:26:06 -04:00

78 lines
2.7 KiB
Diff

Index: configure
===================================================================
--- configure (revision 62657)
+++ configure (revision 63138)
@@ -1,4 +1,4 @@
#! /bin/sh
-# From configure.in Id: configure.in 58872 2009-02-13 09:18:23Z CE .
+# From configure.in Id.
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.59 for wxWidgets 2.8.10.
@@ -26380,7 +26380,7 @@
if test "$ac_cv_header_png_h" = "yes"; then
- echo "$as_me:$LINENO: checking for png_check_sig in -lpng" >&5
-echo $ECHO_N "checking for png_check_sig in -lpng... $ECHO_C" >&6
-if test "${ac_cv_lib_png_png_check_sig+set}" = set; then
+ echo "$as_me:$LINENO: checking for png_sig_cmp in -lpng" >&5
+echo $ECHO_N "checking for png_sig_cmp in -lpng... $ECHO_C" >&6
+if test "${ac_cv_lib_png_png_sig_cmp+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -26400,9 +26400,9 @@
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
-char png_check_sig ();
+char png_sig_cmp ();
int
main ()
{
-png_check_sig ();
+png_sig_cmp ();
;
return 0;
@@ -26430,10 +26430,10 @@
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
- ac_cv_lib_png_png_check_sig=yes
+ ac_cv_lib_png_png_sig_cmp=yes
else
echo "$as_me: failed program was:" >&5
sed 's/^/| /' conftest.$ac_ext >&5
-ac_cv_lib_png_png_check_sig=no
+ac_cv_lib_png_png_sig_cmp=no
fi
rm -f conftest.err conftest.$ac_objext \
@@ -26441,7 +26441,7 @@
LIBS=$ac_check_lib_save_LIBS
fi
-echo "$as_me:$LINENO: result: $ac_cv_lib_png_png_check_sig" >&5
-echo "${ECHO_T}$ac_cv_lib_png_png_check_sig" >&6
-if test $ac_cv_lib_png_png_check_sig = yes; then
+echo "$as_me:$LINENO: result: $ac_cv_lib_png_png_sig_cmp" >&5
+echo "${ECHO_T}$ac_cv_lib_png_png_sig_cmp" >&6
+if test $ac_cv_lib_png_png_sig_cmp = yes; then
PNG_LINK=" -lpng -lz"
fi
Index: docs/changes.txt
===================================================================
--- docs/changes.txt (revision 62511)
+++ docs/changes.txt (revision 63138)
@@ -128,4 +128,5 @@
- Added wxBORDER_THEME to XRC.
- Speeded up wxTreeCtrl by caching text size (botg).
+- Fix building with using system libpng 1.4 (Volker Grabsch).
wxMSW:
Index: configure.in
===================================================================
--- configure.in (revision 62657)
+++ configure.in (revision 63138)
@@ -3051,5 +3051,5 @@
if test "$ac_cv_header_png_h" = "yes"; then
- AC_CHECK_LIB(png, png_check_sig, PNG_LINK=" -lpng -lz", , [-lz -lm])
+ AC_CHECK_LIB(png, png_sig_cmp, PNG_LINK=" -lpng -lz", , [-lz -lm])
fi