slackbuilds_ponce/multimedia/xbmc/patches/0001-Revert-drop-support-for-external-ffmpeg.patch
Larry Hajali a50bc6b094 multimedia/xbmc: Updated for version 13.0_r2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2014-05-20 12:56:40 +07:00

53 lines
2 KiB
Diff

From e55766aa8da7265bea129c70cfd445ad66191fd0 Mon Sep 17 00:00:00 2001
From: Michael Cronenworth <mike@cchtml.com>
Date: Sun, 16 Mar 2014 17:14:03 -0500
Subject: [PATCH 1/2] Revert "drop support for external ffmpeg"
This reverts commit e211654714b2266b80ba65361bda8f715d47933a.
Conflicts:
configure.in
---
configure.in | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/configure.in b/configure.in
index f9f5693..c389b76 100644
--- a/configure.in
+++ b/configure.in
@@ -191,6 +191,9 @@ libcec_disabled="== libcec disabled. CEC adapter support will not be available.
# External library message strings
external_libraries_enabled="== Use of all supported external libraries enabled. =="
external_libraries_disabled="== Use of all supported external libraries disabled. =="
+external_ffmpeg_enabled="== Use of external ffmpeg enabled. =="
+external_ffmpeg_disabled="== Use of external ffmpeg disabled. =="
+ffmpeg_vdpau_not_supported="== External ffmpeg doesn't support VDPAU. VDPAU support disabled. =="
dashes="------------------------"
final_message="\n XBMC Configuration:"
final_message="\n$dashes$final_message\n$dashes"
@@ -569,6 +572,12 @@ AC_ARG_ENABLE([external-libraries],
[use_external_libraries=$enableval],
[use_external_libraries=no])
+AC_ARG_ENABLE([external-ffmpeg],
+ [AS_HELP_STRING([--enable-external-ffmpeg],
+ [enable use of external ffmpeg libraries (default is no) 'Linux only'])],
+ [use_external_ffmpeg=$enableval],
+ [use_external_ffmpeg=$use_external_libraries])
+
AC_ARG_ENABLE([libav-compat],
[AS_HELP_STRING([--enable-libav-compat],
[build a wrapper around libav to provide the functions needed by XBMC. This is
@@ -600,9 +609,6 @@ PKG_PROG_PKG_CONFIG
MAKE="${MAKE:-make}"
OBJDUMP="${OBJDUMP:-objdump}"
-use_external_ffmpeg=no
-use_static_ffmpeg=no
-
# ffmpeg needs the output of uname -s (e.x. linux, darwin) for the target_os
# there is no autoconf variable which will give
# the correct output format when doing cross compilation
--
1.8.5.3