mirror of
https://github.com/Ponce/slackbuilds
synced 2024-12-02 13:04:42 +01:00
2902feffcd
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
48 lines
2.4 KiB
Diff
48 lines
2.4 KiB
Diff
diff -Naur icedtea6-1.13.13.orig/Makefile.am icedtea6-1.13.13/Makefile.am
|
|
--- icedtea6-1.13.13.orig/Makefile.am 2017-01-04 15:22:49.112782727 -0500
|
|
+++ icedtea6-1.13.13/Makefile.am 2021-05-29 23:06:16.902186221 -0400
|
|
@@ -328,6 +328,7 @@
|
|
$(UPSTREAMED_PATCHES) \
|
|
patches/openjdk/6733501-icedtea_lcms_test.patch \
|
|
$(LCMS_PATCHES) \
|
|
+ patches/openjdk/removed-sysctl-h.patch \
|
|
patches/openjdk/7018912-potential_buffer_overruns_in_jpeg.patch \
|
|
patches/openjdk/6989760-native_warnings.patch \
|
|
patches/openjdk/7013519-integer_overflows.patch \
|
|
diff -Naur icedtea6-1.13.13.orig/Makefile.in icedtea6-1.13.13/Makefile.in
|
|
--- icedtea6-1.13.13.orig/Makefile.in 2017-01-04 15:23:00.576597287 -0500
|
|
+++ icedtea6-1.13.13/Makefile.in 2021-05-29 23:06:15.712176245 -0400
|
|
@@ -782,6 +782,7 @@
|
|
$(UPSTREAMED_PATCHES) \
|
|
patches/openjdk/6733501-icedtea_lcms_test.patch \
|
|
$(LCMS_PATCHES) \
|
|
+ patches/openjdk/removed-sysctl-h.patch \
|
|
patches/openjdk/7018912-potential_buffer_overruns_in_jpeg.patch \
|
|
patches/openjdk/6989760-native_warnings.patch \
|
|
patches/openjdk/7013519-integer_overflows.patch \
|
|
diff -Naur icedtea6-1.13.13.orig/patches/openjdk/removed-sysctl-h.patch icedtea6-1.13.13/patches/openjdk/removed-sysctl-h.patch
|
|
--- icedtea6-1.13.13.orig/patches/openjdk/removed-sysctl-h.patch 1969-12-31 19:00:00.000000000 -0500
|
|
+++ icedtea6-1.13.13/patches/openjdk/removed-sysctl-h.patch 2021-05-29 22:22:09.410666831 -0400
|
|
@@ -0,0 +1,22 @@
|
|
+diff -Naur openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c openjdk.new/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c
|
|
+--- openjdk/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c 2016-12-29 23:30:19.000000000 -0500
|
|
++++ openjdk.new/jdk/src/solaris/native/java/net/PlainDatagramSocketImpl.c 2021-05-29 22:20:40.679916383 -0400
|
|
+@@ -35,7 +35,6 @@
|
|
+ #endif
|
|
+ #ifdef __linux__
|
|
+ #include <unistd.h>
|
|
+-#include <sys/sysctl.h>
|
|
+ #include <sys/utsname.h>
|
|
+ #include <netinet/ip.h>
|
|
+
|
|
+diff -Naur openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c openjdk.new/jdk/src/solaris/native/java/net/PlainSocketImpl.c
|
|
+--- openjdk/jdk/src/solaris/native/java/net/PlainSocketImpl.c 2016-12-29 23:30:19.000000000 -0500
|
|
++++ openjdk.new/jdk/src/solaris/native/java/net/PlainSocketImpl.c 2021-05-29 22:20:23.242768734 -0400
|
|
+@@ -43,7 +43,6 @@
|
|
+ #endif
|
|
+ #ifdef __linux__
|
|
+ #include <unistd.h>
|
|
+-#include <sys/sysctl.h>
|
|
+ #endif
|
|
+
|
|
+ #include "jvm.h"
|