mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
1152660bd5
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
26 lines
806 B
Diff
26 lines
806 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -286,7 +286,7 @@
|
|
|
|
if test "x$ssl_ok" = "xyes"; then
|
|
old_libs="$LIBS"
|
|
- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
|
|
+ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
|
|
LIBS="$old_libs"
|
|
fi
|
|
|
|
--- a/dpi/https.c
|
|
+++ b/dpi/https.c
|
|
@@ -476,7 +476,11 @@
|
|
case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
|
|
/*Either self signed and untrusted*/
|
|
/*Extract CN from certificate name information*/
|
|
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
|
if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
|
|
+#else
|
|
+ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
|
|
+#endif
|
|
strcpy(buf, "(no CN given)");
|
|
} else {
|
|
char *cn_end;
|
|
|