mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
8ad56b83a0
Added a patch for parallel builds, two more to fix building on 14.0, and some compiler flags needed for the new gcc-4.7.x. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
58 lines
2.2 KiB
Diff
58 lines
2.2 KiB
Diff
diff -ur wvstreams-4.6.1.orig/Makefile wvstreams-4.6.1/Makefile
|
|
--- wvstreams-4.6.1.orig/Makefile 2009-09-16 00:26:50.000000000 +0300
|
|
+++ wvstreams-4.6.1/Makefile 2010-01-04 18:06:15.000000000 +0200
|
|
@@ -131,12 +131,19 @@
|
|
# libwvstreams: stream/event handling library
|
|
#
|
|
TARGETS += libwvstreams.so
|
|
-TARGETS += crypto/tests/ssltest ipstreams/tests/unixtest
|
|
+TARGETS += crypto/tests/ssltest
|
|
+crypto/tests/ssltest: $(LIBWVSTREAMS)
|
|
+
|
|
+TARGETS += ipstreams/tests/unixtest
|
|
+ipstreams/tests/unixtest: $(LIBWVSTREAMS)
|
|
+
|
|
TARGETS += crypto/tests/printcert
|
|
+crypto/tests/printcert: $(LIBWVSTREAMS)
|
|
|
|
ifndef _MACOS
|
|
ifneq ("$(with_readline)", "no")
|
|
TARGETS += ipstreams/tests/wsd
|
|
+ ipstreams/tests/wsd: $(LIBWVSTREAMS)
|
|
ipstreams/tests/wsd-LIBS += -lreadline
|
|
else
|
|
TEST_SKIP_OBJS += ipstreams/tests/wsd
|
|
@@ -179,7 +186,11 @@
|
|
#
|
|
ifneq ("$(with_dbus)", "no")
|
|
TARGETS += libwvdbus.so
|
|
- TARGETS += dbus/tests/wvdbus dbus/tests/wvdbusd
|
|
+ TARGETS += dbus/tests/wvdbus
|
|
+ dbus/tests/wvdbus: $(LIBWVDBUS)
|
|
+
|
|
+ TARGETS += dbus/tests/wvdbusd
|
|
+ dbus/tests/wvdbusd: $(LIBWVDBUS)
|
|
TESTS += $(call tests_cc,dbus/tests)
|
|
libwvdbus_OBJS += $(call objects,dbus)
|
|
libwvdbus.so: $(libwvdbus_OBJS) $(LIBWVSTREAMS)
|
|
diff -ur wvstreams-4.6.1.orig/wvrules-posix.mk wvstreams-4.6.1/wvrules-posix.mk
|
|
--- wvstreams-4.6.1.orig/wvrules-posix.mk 2008-10-21 18:31:58.000000000 +0300
|
|
+++ wvstreams-4.6.1/wvrules-posix.mk 2010-01-04 18:04:00.000000000 +0200
|
|
@@ -85,12 +85,15 @@
|
|
$(AR) s $1
|
|
endef
|
|
|
|
-CC: FORCE
|
|
+CC:
|
|
@CC="$(CC)" CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
|
|
$(WVSTREAMS)/gen-cc CC c
|
|
|
|
-CXX: FORCE
|
|
+CXX:
|
|
@CC="$(CXX)" CFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" \
|
|
$(WVSTREAMS)/gen-cc CXX cc
|
|
|
|
+#All files must depend on the above two rules. This is a godawful hack.
|
|
+$(shell find -type f '(' -name '*.c' -o -name '*.cc' ')' ): CC CXX
|
|
+
|
|
wvlink=$(LINK_MSG)$(WVLINK_CC) $(LDFLAGS) $($1-LDFLAGS) -o $1 $(filter %.o %.a %.so, $2) $($1-LIBS) $(XX_LIBS) $(LDLIBS) $(PRELIBS) $(LIBS)
|