slackbuilds_ponce/desktop/bar/patches/bar-Makefile-CFLAGS.patch
John Vogel e7695c5163 desktop/bar: Added (lightweight bar based on XCB)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
2014-04-12 13:59:47 -05:00

13 lines
369 B
Diff

diff --git a/Makefile b/Makefile
index ff620a8..01b6bf9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
CC ?= gcc
STRIP ?= strip
-CFLAGS = -std=c99 -Os
+CFLAGS ?= -Os
+CFLAGS += -std=c99
LDFLAGS = -lxcb -lxcb-xinerama -lxcb-randr
CFDEBUG = -g3 -pedantic -Wall -Wunused-parameter -Wlong-long\
-Wsign-conversion -Wconversion -Wimplicit-function-declaration