mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-26 22:06:35 +01:00
71040f50ae
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
--- 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO.orig/Makefile 2011-07-19 10:56:36.000000000 +0200
|
|
+++ 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO/Makefile 2012-06-20 15:13:00.545541237 +0200
|
|
@@ -170,10 +170,10 @@
|
|
|
|
ifeq ($(PLATFORM),PC)
|
|
# Linux 2.6
|
|
-LINUX_SRC = /lib/modules/$(shell uname -r)/build
|
|
+LINUX_SRC = /lib/modules/$(KERNEL)/build
|
|
# Linux 2.4 Change to your local setting
|
|
#LINUX_SRC = /usr/src/linux-2.4
|
|
-LINUX_SRC_MODULE = /lib/modules/$(shell uname -r)/kernel/drivers/net/wireless/
|
|
+LINUX_SRC_MODULE = /lib/modules/$(KERNEL)/kernel/drivers/net/wireless/
|
|
CROSS_COMPILE =
|
|
endif
|
|
|
|
@@ -339,7 +339,7 @@
|
|
cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)apsta.o /tftpboot
|
|
endif
|
|
else
|
|
- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.o /tftpboot
|
|
+ true
|
|
ifeq ($(OSABL),YES)
|
|
cp -f $(RT28xx_DIR)/os/linux/rtutil$(CHIPSET)sta.o /tftpboot
|
|
cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)sta.o /tftpboot
|
|
@@ -385,7 +385,7 @@
|
|
cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)apsta.ko /tftpboot
|
|
endif
|
|
else
|
|
- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
|
|
+ true
|
|
ifeq ($(OSABL),YES)
|
|
cp -f $(RT28xx_DIR)/os/linux/rtutil$(CHIPSET)sta.ko /tftpboot
|
|
cp -f $(RT28xx_DIR)/os/linux/rtnet$(CHIPSET)sta.ko /tftpboot
|