slackbuilds_ponce/development/gcc5/patches/gcc-no_fixincludes.diff
Eric Hameleers 57a75502dd development/gcc5: Added (gcc version 5 C, C++ and Java compilers).
Signed-off-by: Eric Hameleers <alien@slackware.com>

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2021-04-18 12:22:49 +02:00

27 lines
1.1 KiB
Diff

--- ./gcc/Makefile.in.orig 2010-04-02 02:49:06.000000000 -0500
+++ ./gcc/Makefile.in 2010-08-01 16:55:30.088318841 -0500
@@ -3864,9 +3864,9 @@
chmod a+r $${fix_dir}/limits.h; \
done
# Install the README
- rm -f include-fixed/README
- cp $(srcdir)/../fixincludes/README-fixinc include-fixed/README
- chmod a+r include-fixed/README
+# rm -f include-fixed/README
+# cp $(srcdir)/../fixincludes/README-fixinc include-fixed/README
+# chmod a+r include-fixed/README
$(STAMP) $@
.PHONY: install-gcc-tooldir
@@ -3947,10 +3947,7 @@
(TARGET_MACHINE='$(target)'; srcdir=`cd $(srcdir); ${PWD_COMMAND}`; \
SHELL='$(SHELL)'; MACRO_LIST=`${PWD_COMMAND}`/macro_list ; \
gcc_dir=`${PWD_COMMAND}` ; \
- export TARGET_MACHINE srcdir SHELL MACRO_LIST && \
- cd $(build_objdir)/fixincludes && \
- $(SHELL) ./fixinc.sh "$${gcc_dir}/$${fix_dir}" \
- $(SYSTEM_HEADER_DIR) $(OTHER_FIXINCLUDES_DIRS) ); \
+ export TARGET_MACHINE srcdir SHELL MACRO_LIST ); \
rm -f $${fix_dir}/syslimits.h; \
if [ -f $${fix_dir}/limits.h ]; then \
mv $${fix_dir}/limits.h $${fix_dir}/syslimits.h; \