slackbuilds_ponce/games/FlightGear/explicitly-link-with-libX11.patch
David Spencer 860b5f6e9a games/FlightGear: Build with extra/fltk.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
2016-01-16 23:36:53 -06:00

36 lines
1 KiB
Diff

From 04ca64edc46cfb54ecff5bddf12370b2c7a0f192 Mon Sep 17 00:00:00 2001
From: Fabrice Bellet <fabrice@bellet.info>
Date: Tue, 17 Feb 2015 22:49:50 +0100
Subject: [PATCH] explicitely link with libX11
---
src/Main/CMakeLists.txt | 1 +
utils/fgviewer/CMakeLists.txt | 1 +
2 files changed, 2 insertions(+)
diff --git a/src/Main/CMakeLists.txt b/src/Main/CMakeLists.txt
index 12c0961..78c4163 100644
--- a/src/Main/CMakeLists.txt
+++ b/src/Main/CMakeLists.txt
@@ -142,6 +142,7 @@ target_link_libraries(fgfs
${SIMGEAR_CORE_LIBRARY_DEPENDENCIES}
${SIMGEAR_SCENE_LIBRARY_DEPENDENCIES}
${PLATFORM_LIBS}
+ ${X11_X11_LIB}
)
if(ENABLE_FLITE)
diff --git a/utils/fgviewer/CMakeLists.txt b/utils/fgviewer/CMakeLists.txt
index 165be74..065b8f1 100644
--- a/utils/fgviewer/CMakeLists.txt
+++ b/utils/fgviewer/CMakeLists.txt
@@ -48,5 +48,6 @@ target_link_libraries(fgviewer
${OPENGL_LIBRARIES}
${FGVIEWER_RTI_LIBRARIES}
${SIMGEAR_CORE_LIBRARY_DEPENDENCIES}
+ ${X11_X11_LIB}
)
install(TARGETS fgviewer RUNTIME DESTINATION bin)
--
2.1.0