slackbuilds_ponce/multimedia/farsight2/make-4.3.patch
Matteo Bernardini 2e76545b3b multimedia/farsight2: Fix for gcc >= 10.x, patch for make >= 4.3.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2021-04-17 23:22:25 -05:00

122 lines
5 KiB
Diff

Matteo Bernardini <ponce@slackbuilds.org>
fix it like https://gitweb.gentoo.org/repo/gentoo.git/plain/net-libs/farstream/files/farstream-0.2.8-make43.patch
diff -Naur farsight2-0.0.31.orig/common/glib-gen.mak farsight2-0.0.31/common/glib-gen.mak
--- farsight2-0.0.31.orig/common/glib-gen.mak 2010-10-08 18:38:56.000000000 +0200
+++ farsight2-0.0.31/common/glib-gen.mak 2021-02-16 09:48:20.885387000 +0100
@@ -1,11 +1,13 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_enum_prefix=gst_color_balance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
%-marshal.h: %-marshal.list
diff -Naur farsight2-0.0.31.orig/common/gst-glib-gen.mak farsight2-0.0.31/common/gst-glib-gen.mak
--- farsight2-0.0.31.orig/common/gst-glib-gen.mak 2010-10-08 18:38:56.000000000 +0200
+++ farsight2-0.0.31/common/gst-glib-gen.mak 2021-02-16 09:47:43.231387000 +0100
@@ -1,12 +1,14 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
#glib_gen_basename=colorbalance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
diff -Naur farsight2-0.0.31.orig/common-modified/gst-glib-gen.mak farsight2-0.0.31/common-modified/gst-glib-gen.mak
--- farsight2-0.0.31.orig/common-modified/gst-glib-gen.mak 2011-09-07 22:20:18.000000000 +0200
+++ farsight2-0.0.31/common-modified/gst-glib-gen.mak 2021-02-16 09:48:55.282387000 +0100
@@ -1,12 +1,14 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
#glib_gen_basename=colorbalance
-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers=$(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
# these are all the rules generating the relevant files
$(glib_gen_basename)-marshal.h: $(glib_gen_basename)-marshal.list
diff -Naur farsight2-0.0.31.orig/gst/fsrtpconference/Makefile.in farsight2-0.0.31/gst/fsrtpconference/Makefile.in
--- farsight2-0.0.31.orig/gst/fsrtpconference/Makefile.in 2011-10-10 21:59:55.000000000 +0200
+++ farsight2-0.0.31/gst/fsrtpconference/Makefile.in 2021-02-16 09:49:52.456387000 +0100
@@ -18,6 +18,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -458,7 +460,7 @@
glib_enum_define = FS_RTP
glib_gen_prefix = _fs_rtp
glib_gen_basename = fs-rtp
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
all: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) all-am
diff -Naur farsight2-0.0.31.orig/gst-libs/gst/farsight/Makefile.in farsight2-0.0.31/gst-libs/gst/farsight/Makefile.in
--- farsight2-0.0.31.orig/gst-libs/gst/farsight/Makefile.in 2011-10-10 21:59:55.000000000 +0200
+++ farsight2-0.0.31/gst-libs/gst/farsight/Makefile.in 2021-02-16 09:50:34.663387000 +0100
@@ -18,6 +18,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -438,7 +440,7 @@
glib_enum_define = FS
glib_gen_prefix = _fs
glib_gen_basename = fs
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
all: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) all-am
diff -Naur farsight2-0.0.31.orig/transmitters/rawudp/Makefile.in farsight2-0.0.31/transmitters/rawudp/Makefile.in
--- farsight2-0.0.31.orig/transmitters/rawudp/Makefile.in 2011-10-10 21:59:56.000000000 +0200
+++ farsight2-0.0.31/transmitters/rawudp/Makefile.in 2021-02-16 09:51:10.249387000 +0100
@@ -18,6 +18,8 @@
# these are the variables your Makefile.am should set
# the example is based on the colorbalance interface
+H := \#
+
#glib_enum_headers=$(colorbalance_headers)
#glib_enum_define=GST_COLOR_BALANCE
#glib_gen_prefix=gst_color_balance
@@ -392,7 +394,7 @@
glib_enum_define = FS_RAWUDP
glib_gen_prefix = _fs_rawudp
glib_gen_basename = fs-rawudp
-enum_headers = $(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
+enum_headers = $(foreach h,$(glib_enum_headers),\n$(H)include \"$(h)\")
all: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) all-am