slackbuilds_ponce/games/0ad/rust-1.50.0.patch
Matteo Bernardini 018ccee47b games/0ad: Updated for version 0.0.24b.
patch for the newer rust, add the dep fmt

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2021-04-17 22:49:11 -05:00

40 lines
2.2 KiB
Diff

diff -Naur mozjs-78.6.0.orig/.cargo/config.in mozjs-78.6.0/.cargo/config.in
--- mozjs-78.6.0.orig/.cargo/config.in 2020-11-28 17:33:01.000000000 +0100
+++ mozjs-78.6.0/.cargo/config.in 2021-02-26 08:45:50.995837000 +0100
@@ -3,9 +3,9 @@
# Please do not edit.
[source."https://github.com/shravanrn/nix/"]
-branch = "r0.13.1"
git = "https://github.com/shravanrn/nix/"
replace-with = "vendored-sources"
+rev = "4af6c367603869a30fddb5ffb0aba2b9477ba92e"
[source."https://github.com/mozilla/rkv"]
git = "https://github.com/mozilla/rkv"
diff -Naur mozjs-78.6.0.orig/Cargo.lock mozjs-78.6.0/Cargo.lock
--- mozjs-78.6.0.orig/Cargo.lock 2020-11-28 17:33:01.000000000 +0100
+++ mozjs-78.6.0/Cargo.lock 2021-02-26 08:47:06.265837000 +0100
@@ -3200,7 +3200,7 @@
[[package]]
name = "nix"
version = "0.13.1"
-source = "git+https://github.com/shravanrn/nix/?branch=r0.13.1#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
+source = "git+https://github.com/shravanrn/nix/?rev=4af6c367603869a30fddb5ffb0aba2b9477ba92e#4af6c367603869a30fddb5ffb0aba2b9477ba92e"
dependencies = [
"bitflags",
"cc",
diff -Naur mozjs-78.6.0.orig/Cargo.toml mozjs-78.6.0/Cargo.toml
--- mozjs-78.6.0.orig/Cargo.toml 2020-11-28 17:34:26.000000000 +0100
+++ mozjs-78.6.0/Cargo.toml 2021-02-26 08:48:06.663837000 +0100
@@ -60,8 +60,8 @@
[patch.crates-io]
packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="3541e3818fdc7c2a24f87e3459151a4ce955a67a" }
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
+nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu4" }
# failure's backtrace feature might break our builds, see bug 1608157.
failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }