mirror of
https://github.com/Ponce/slackbuilds
synced 2024-12-02 13:04:42 +01:00
6fbbe774f2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
21 lines
700 B
Diff
21 lines
700 B
Diff
--- CMakeLists.txt 2022-08-23 14:57:53.000000000 +0530
|
|
+++ cmakelistn.txt 2023-02-06 18:26:55.129000000 +0530
|
|
@@ -1,9 +1,9 @@
|
|
-cmake_minimum_required(VERSION 2.8)
|
|
+cmake_minimum_required(VERSION 3.10)
|
|
|
|
project(uavs3e)
|
|
|
|
aux_source_directory(./test DIR_SRC_TEST)
|
|
-set_source_files_properties(${DIR_SRC_TEST} PROPERTIES COMPILE_FLAGS "${CMAKE_C_FLAGS} -std=c99 -O3")
|
|
+set_source_files_properties(${DIR_SRC_TEST} PROPERTIES COMPILE_FLAGS "${CMAKE_C_FLAGS} -std=c99 -O2")
|
|
|
|
add_subdirectory(./src)
|
|
include_directories("./inc")
|
|
@@ -20,5 +20,4 @@
|
|
|
|
target_link_libraries(uavs3enc m)
|
|
target_link_libraries(uavs3enc uavs3e)
|
|
-#target_link_libraries(uavs3enc dl)
|
|
-
|
|
+target_link_libraries(uavs3enc dl)
|