slackbuilds_ponce/desktop/icewm/patches/icewm-1.3.7-fix_html_docdir.diff
Robby Workman deaf02228b desktop/icewm: Included a couple of build fix patches
These are only needed for -current, but they don't hurt anything
for 13.37 and they reduce the workload later when getting all of
the repo ready for slackware-next.

Thanks to Morten Langlo for the fontconfig patch.

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
2012-05-14 13:13:58 -05:00

24 lines
1.5 KiB
Diff

diff -Nur icewm-1.3.7.orig/src/Makefile icewm-1.3.7/src/Makefile
--- icewm-1.3.7.orig/src/Makefile 2010-10-31 09:09:49.000000000 -0500
+++ icewm-1.3.7/src/Makefile 2011-09-04 21:59:06.658236001 -0500
@@ -32,7 +32,7 @@
-DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
-DICESMEXE='"icewm-session$(EXEEXT)"' \
-DICEHELPEXE='"icehelp$(EXEEXT)"' \
- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
+ -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/html/icewm.html"'
CXXFLAGS = -fpermissive -Wall -Wpointer-arith -Wwrite-strings -Woverloaded-virtual -W -fno-exceptions -fno-rtti -g -O2 $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
-I/usr/include/freetype2 -pthread -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include # `fc-config --cflags`
diff -Nur icewm-1.3.7.orig/src/Makefile.in icewm-1.3.7/src/Makefile.in
--- icewm-1.3.7.orig/src/Makefile.in 2010-10-31 09:09:36.000000000 -0500
+++ icewm-1.3.7/src/Makefile.in 2011-09-04 21:59:06.659235991 -0500
@@ -32,7 +32,7 @@
-DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
-DICESMEXE='"icewm-session$(EXEEXT)"' \
-DICEHELPEXE='"icehelp$(EXEEXT)"' \
- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
+ -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/html/icewm.html"'
CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
@CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`