slackbuilds_ponce/libraries/poco/poco_x64.patch
Dimitris Zlatanidis 07474dacc2 libraries/poco: Added (C++ class libraries).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2014-03-21 13:01:14 -05:00

22 lines
1.3 KiB
Diff

--- poco-1.4.6p2-all/Makefile.original 2014-03-13 14:12:58.141661715 +0700
+++ poco-1.4.6p2-all/Makefile 2014-03-13 14:14:32.910933057 +0700
@@ -33,7 +33,7 @@
install: libexecs
mkdir -p $(INSTALLDIR)/include/Poco
- mkdir -p $(INSTALLDIR)/lib
+ mkdir -p $(INSTALLDIR)/lib64
mkdir -p $(INSTALLDIR)/bin
for comp in $(COMPONENTS) ; do \
if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
@@ -43,8 +43,8 @@
find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
fi ; \
done
- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
+ find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib64 \;
+ find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib64 \;
libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests