slackbuilds_ponce/libraries/RxCpp/RxCpp.patch
Andre Barboza 84dece812f libraries/RxCpp: Updated for version 4.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2017-03-24 20:22:24 +07:00

38 lines
2.2 KiB
Diff

diff -ur RxCpp-4.0.0.old/projects/CMake/CMakeLists.txt RxCpp-4.0.0/projects/CMake/CMakeLists.txt
--- RxCpp-4.0.0.old/projects/CMake/CMakeLists.txt 2017-03-22 23:13:15.000000000 -0300
+++ RxCpp-4.0.0/projects/CMake/CMakeLists.txt 2017-03-23 20:16:59.520017863 -0300
@@ -11,18 +11,18 @@
MESSAGE( STATUS "RXCPP_DIR: " ${RXCPP_DIR} )
-add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
+#add_subdirectory(${RXCPP_DIR}/Rx/v2/test ${CMAKE_CURRENT_BINARY_DIR}/test)
add_subdirectory(${RXCPP_DIR}/projects/doxygen ${CMAKE_CURRENT_BINARY_DIR}/projects/doxygen)
-set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
+#set(EXAMPLES_DIR ${RXCPP_DIR}/Rx/v2/examples)
-add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
-add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
-add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
-add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
-add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
-add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
+#add_subdirectory(${EXAMPLES_DIR}/cep ${CMAKE_CURRENT_BINARY_DIR}/examples/cep)
+#add_subdirectory(${EXAMPLES_DIR}/stop ${CMAKE_CURRENT_BINARY_DIR}/examples/stop)
+#add_subdirectory(${EXAMPLES_DIR}/linesfrombytes ${CMAKE_CURRENT_BINARY_DIR}/examples/linesfrombytes)
+#add_subdirectory(${EXAMPLES_DIR}/println ${CMAKE_CURRENT_BINARY_DIR}/examples/println)
+#add_subdirectory(${EXAMPLES_DIR}/pythagorian ${CMAKE_CURRENT_BINARY_DIR}/examples/pythagorian)
+#add_subdirectory(${EXAMPLES_DIR}/tests ${CMAKE_CURRENT_BINARY_DIR}/examples/tests)
# The list of RxCpp source files. Please add every new file to this list
set(RX_SOURCES
@@ -133,5 +133,6 @@
set(CMAKE_SKIP_INSTALL_ALL_DEPENDENCY TRUE CACHE BOOL "Don't require all projects to be built in order to install" FORCE)
-install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION rxcpp
+install(DIRECTORY ${RXCPP_DIR}/Rx/v2/src/rxcpp/ DESTINATION include/rxcpp
FILES_MATCHING PATTERN "*.hpp")
+install(TARGETS RxCpp DESTINATION lib${LIB_SUFFIX})