slackbuilds_ponce/python/python-dateutil/python-dateutil-2.1-open-utf-8.patch
Larry Hajali c1a8fd4994 python/python-dateutil: Updated for version 2.1, added license.
Also added the new dependency six

Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
2012-12-27 17:56:20 +01:00

20 lines
552 B
Diff

=== modified file 'setup.py'
--- setup.py 2012-04-29 13:32:22 +0000
+++ setup.py 2012-04-29 13:34:16 +0000
@@ -1,5 +1,6 @@
#!/usr/bin/python
from os.path import isfile, join
+import codecs
import glob
import os
import re
@@ -13,7 +14,7 @@
TOPDIR = os.path.dirname(__file__) or "."
VERSION = re.search('__version__ = "([^"]+)"',
- open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
+ codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
setup(name="python-dateutil",