slackbuilds_ponce/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
Dimitris Zlatanidis ef100fc927 system/ttyrec: Added (tty recorder).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2015-07-04 10:38:14 +07:00

33 lines
935 B
Diff

diff -rupN original/Makefile new/Makefile
--- original/Makefile 2006-06-11 10:52:50.000000000 -0500
+++ new/Makefile 2012-04-23 18:34:05.000000000 -0500
@@ -1,5 +1,5 @@
CC = gcc
-CFLAGS = -O2
+CFLAGS = -O2 -DHAVE_openpty
VERSION = 1.0.8
TARGET = ttyrec ttyplay ttytime
@@ -10,7 +10,7 @@ DIST = ttyrec.c ttyplay.c ttyrec.h io.c
all: $(TARGET)
ttyrec: ttyrec.o io.o
- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
+ $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o -lutil
ttyplay: ttyplay.o io.o
$(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
diff -rupN original/ttyrec.c new/ttyrec.c
--- original/ttyrec.c 2006-06-11 10:52:50.000000000 -0500
+++ new/ttyrec.c 2012-04-23 18:26:41.000000000 -0500
@@ -71,7 +71,9 @@
#define _(FOO) FOO
#ifdef HAVE_openpty
-#include <libutil.h>
+/* #include <libutil.h> */
+#include <pty.h> /* for openpty and forkpty */
+#include <utmp.h> /* for login_tty */
#endif
#if defined(SVR4) && !defined(CDEL)